bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

make Teaching Kits print nice

RESOLVED DUPLICATE of bug 990117

Status

Webmaker
General
RESOLVED DUPLICATE of bug 990117
5 years ago
4 years ago

People

(Reporter: epilepticrabbit, Assigned: Michael V)

Tracking

Details

(Whiteboard: [mentor][crossteambugs] [workweek][teachingkit], URL)

(Reporter)

Description

5 years ago
We should make it easy for people to print the teaching kits. 

--URLs listed at the end/with footnotes instead of in the page
--kits should print corresponding activities
--multiple pages should be printed (I only ever got one. I admit to test printing on only 2 printers, though several times)
--kits should include print button(?)
Additionally we should probably pop the make out of the remix wrapper (iframe) for print. It's not useful in a printed state :P
+1 to all of the above.
Michael, I wonder if you could take this bug.  It would involve creating a .css file that can be re-used across Webmaker and does @media=print (see https://developer.mozilla.org/en-US/docs/Web/CSS/@media#Media_types).  It seems like something that fits with what you're interested in doing this term.

I've CC'ed Kate for thoughts, and to see if she could mentor a bit.
Assignee: nobody → mikev370
Status: NEW → ASSIGNED
I think the main issue here is that if you try to print the details bar (e.g. https://mozteach.makes.org/thimble/make-your-own-teaching-kit) instead of the inner content (https://mozteach.makes.org/thimble/make-your-own-teaching-kit_)

Michael, could you add a 'Print' button that would focus on the iframe and print the contents, or else redirect to the inner page and then print?
There is already a print stylesheet in thimble pages that seems to be fairly decent, it just is not getting applied because the iframe is not aware of what's going on on the page.
Whiteboard: [mentor][crossteambugs][webmaker workweek] → [mentor][crossteambugs] [workweek]
Component: Editorial → General
Product: Webmaker → Webmaker
Whiteboard: [mentor][crossteambugs] [workweek] → [mentor][crossteambugs] [workweek][kit]
(Reporter)

Comment 6

4 years ago
Just wanted to check on progress after this conversation over twitter:

>>hey @epilepticrabbit , @katermouse asked me a great question this am. any plan to optimize kits/lessons on wm.org to print?

>>Oh yes @malesser @katermouse I filed this bug a while ago, and it’s been assigned so hopefully soon! bugzilla.mozilla.org/show_bug.cgi?i… #TeachTheWeb
 
>>@epilepticrabbit Great news! As much as I believe in decreasing paper use, I know teachers like to have things in-hand. @malesser
Whiteboard: [mentor][crossteambugs] [workweek][kit] → [mentor][crossteambugs] [workweek][teachingkit]
This is now a Dupe of bug 990117. or visa versa but one is resolved and the other isnt right now... so duping this one for simplicity
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 990117
You need to log in before you can comment on or make changes to this bug.