[CostControl] In dual sim devices with a SIM card with PIN required but not inserted different behavior when access to cost control aplication

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Assigned: eragonj)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Pre-requesites:
1. Dual SIM device.
2. SIM 1 inserted with PIN required but not inserted.
3. SIM 2 no inserted.
4. Settings SIM manager: SIM 1

Steps:
1. Tap Cost control --> Result: Show PIN required screen
2. Press "Skip" button --> Result: Show screen " Locked SIM card. Unlock your SIM to enabe usage"
3. Press "OK" button
4. Tap Cost control

Actual result:
Show screen " Locked SIM card. Unlock your SIM to enabe usage"

Expected result:
Show PIN required screen and when press "Skip" button you can see " Locked SIM card. Unlock your SIM to enabe usage" screen
(Reporter)

Updated

4 years ago
blocking-b2g: --- → 1.4?
IMO this bug may be a system bug, because the PIN screen is launched by the system, not by the costcontrol application.
Hi Alive,

Could you please have a look at this unexpected behaviour?. Thanks!
Flags: needinfo?(alive)
Hi, from comment 0 I don't understand what's unexpected here. Could you explain more?
Flags: needinfo?(alive)
(Reporter)

Comment 4

4 years ago
First time you tap cost control application (with tpre-requisites) you see a behavior different that second time you tap cost control application.
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #3)
> Hi, from comment 0 I don't understand what's unexpected here. Could you
> explain more?

Hi,

Failing scenarios:
scenario #1 (described in comment 0):
1. Dual SIM device.
2. SIM 1 inserted with PIN required but not inserted.
3. SIM 2 no inserted.
4. Settings SIM manager: SIM 1
scenario #2:
1. Dual SIM device.
2. SIM 2 inserted with PIN required but not inserted.
3. SIM 1 no inserted.
4. Settings SIM manager: SIM 2

STR scenario #1:
1- Launch DataUSage app -> Enter SIM PIN window appears
2- select "Skip"button, then
"Locked SIM card
Unlock your SIM to enable Usage." message appears -> DataUsage app is closed
3- Launch DataUsage app 

STR scenario #2:
1- Launch DataUSage app -> Enter SIM PIN window appears
2- select "Skip"button, then
"No SIM inserted
Insert a SIM to enable Usage." message appears -> DataUsage app is closed
3- Launch DataUsage app 

Expected behavior:
Enter SIM PIN window always appears under a locked SIM card scenario when launching DataUsage app

Current behavior:
Instead of appearing "Enter SIM PIN" window, "Locked SIM card/Insert SIM card" message is shown, it should be shown just in case users skip "Enter SIM PIN" process. It works fine under a single SIM card scenario but fails under scenario #1 and #2

Notice that the third time the app is launched it works fine again, the fourth fails, the fifth works again, the sixth fails and so on and so forth
Thanks, interesting. Does this occur on v1.3?
Component: Gaia::Cost Control → Gaia::System
Hi [:小龍哥],
are you interested in this bug?
Flags: needinfo?(ejchen)
(In reply to Alive Kuo [:alive][NEEDINFO!] from comment #6)
> Thanks, interesting. Does this occur on v1.3?

Hi,

This issue is NOT reproducible in v1.3, scenario #1 and scenario #2 work as expected (always showing "Enter SIM PIN" window and when skipping showing "Locked SIM card" message)

Build information (taken out from objdir-gecko/dist/b2g/application.ini) and gecko and gaia commit hashes:

Vendor=Mozilla
Name=B2G
Version=28.0a2
BuildID=20140120102522
SourceRepository=6ea72307375cfa123d2ec81f29ccc86976134b2a
ID={3c2e2abc-06d4-11e1-ac3b-374f68613e61}

Gecko commit hash:
commit 6ea72307375cfa123d2ec81f29ccc86976134b2a
Author: Ryan VanderMeulen <ryanvm@gmail.com>
Date:   Sun Jan 19 23:04:26 2014 -0500

Gaia commit hash:
commit 726ae682da9022bdccc057f29e836eff6a738677
Merge: 50d6487 3d63ea7
Author: AndreiH <andrei.hutusoru@gmail.com>
Date:   Sun Jan 19 22:57:59 2014 -0800
Sounds like that makes this a regression on 1.4.
Keywords: regression
I can check this later after finishing my works :D
Flags: needinfo?(ejchen)
Tested on latest Gaia but can't reproduce this problem by following STR.

For me, no matter which card is inserted, each time when tapping data usage app, they all show 
"Locked SIM card. Unlock your SIM to enabe usage" on the screen. 

Does this problem still exist or not ?

-- info --

Gaia      988c320bccfa7f873dc2ef3e7c34a11a9f4ad409
Gecko     27679ccd1be8e5a387c0985a693ab58f40917fef
BuildID   20140207061647
Version   28.0
ro.build.version.incremental=eng.enpei.20140116.173941
ro.build.date=Thu Jan 16 17:56:35 CST 2014
Marking qawanted for retest.
Keywords: qawanted
Component: Gaia::System → Gaia::Cost Control
(In reply to Jason Smith [:jsmith] from comment #12)
> Marking qawanted for retest.

Enpei mentioned this offline - we already know this doesn't reproduce on 1.3.
Keywords: qawanted
Assignee: nobody → ejchen
(In reply to Noemí Freire (:noemi) from comment #5)
> Failing scenarios:
> scenario #1 (described in comment 0):
> 1. Dual SIM device.
> 2. SIM 1 inserted with PIN required but not inserted.
> 3. SIM 2 no inserted.
> 4. Settings SIM manager: SIM 1

Hi Noemi, 

can you be more clear about the step 2 ?

I can't understand what is `SIM 1 inserted with PIN required but not inserted`. Should I insert a pin-locked PIM to test or not ????? 

If yes, it means that I have to insert only one pin-locked PIM in my DSDS device and start to tap `cost control` app to test whether SIM pin dialog would popup unexpectedly or not.

But unfortunately in this case, I can't reproduce it with latest code from Gaia. (Please check my device information below)

--
Gaia      6e71ab4da1b08586ea0c758edb7aa199ee34cd2f
Gecko     47debb45e8ab76754399cbcbc91131dd15be632f
BuildID   20140219171005
Version   30.0a1
ro.build.version.incremental=eng.root.20140203.161530
ro.build.date=Mon Feb  3 16:35:44 CST 2014
--

Can you try again ? Thanks.
Created attachment 8378775 [details]
959588.log
(In reply to EJ Chen [:eragonj][:小龍哥] from comment #14)
> (In reply to Noemí Freire (:noemi) from comment #5)
> > Failing scenarios:
> > scenario #1 (described in comment 0):
> > 1. Dual SIM device.
> > 2. SIM 1 inserted with PIN required but not inserted.
> > 3. SIM 2 no inserted.
> > 4. Settings SIM manager: SIM 1
> 
> Hi Noemi, 
> 
> can you be more clear about the step 2 ?
> 
> I can't understand what is `SIM 1 inserted with PIN required but not
> inserted`. Should I insert a pin-locked PIM to test or not ????? 
> 
> If yes, it means that I have to insert only one pin-locked PIM in my DSDS
> device and start to tap `cost control` app to test whether SIM pin dialog
> would popup unexpectedly or not.

Yes, you're right, it means you only have SIM1 inserted and being in "SIM PIN" status (SIM locked)
> 
> But unfortunately in this case, I can't reproduce it with latest code from
> Gaia. (Please check my device information below)
> 
> --
> Gaia      6e71ab4da1b08586ea0c758edb7aa199ee34cd2f
> Gecko     47debb45e8ab76754399cbcbc91131dd15be632f
> BuildID   20140219171005
> Version   30.0a1
> ro.build.version.incremental=eng.root.20140203.161530
> ro.build.date=Mon Feb  3 16:35:44 CST 2014
> --
> 
> Can you try again ? Thanks.

I've tried even with an older master build than the one you mention and it also works fine so marking this bug as RESOLVED WORKSFORME. Thanks!
Status: NEW → RESOLVED
blocking-b2g: 1.4? → ---
Last Resolved: 4 years ago
Keywords: regression
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.