[dev] Adding a review to an app doesn't appear only after second review

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Public Pages
RESOLVED WONTFIX
4 years ago
2 years ago

People

(Reporter: AndreiH, Unassigned)

Tracking

({regression})

unspecified
2014-01-21
regression

Details

(Reporter)

Description

4 years ago
Our automated test intermittently fails because when adding a review to an app (eg. Memchaser) it doesn't appear only after posting a second review.

STR:
1. Go to https://addons-dev.allizom.org and login.
2. Search for MemChaser app and post a review.
3. Inspect the review posted.

Here is a screencast:
http://screencast.com/t/dCAtyquCg
I am seeing similar issues with reviews on dev. Sometimes I'll add a review and it will never appear. I also tried deleting a review that I added. It first appeared with a status of `Marked for deletion`, but then, when I refreshed the reviews page it appeared with a normal status again and the option to `Delete review` was present again.
I spoke to Krupa and there are a bunch of issues with caching on amo dev at the moment. I think we need to wait until that gets resolved before expecting our tests to pass.

Updated

4 years ago
Keywords: regression
Target Milestone: --- → 2014-01-21
Thanks for filing this.  Due to resource constraints we are closing bugs which we won't realistically be able to fix.  If you have a patch that applies to this bug please reopen.

For more info see http://micropipes.com/blog/2014/09/24/the-great-add-on-bug-triage/
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.