Alert in oninput of number/range freezes window, cannot be closed with mouse clicks

REOPENED
Unassigned

Status

()

Core
Layout: Form Controls
REOPENED
4 years ago
4 years ago

People

(Reporter: obrufau, Unassigned)

Tracking

29 Branch
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20140115])

Attachments

(1 attachment)

399 bytes, text/html
Details
(Reporter)

Description

4 years ago
Created attachment 8359858 [details]
Demo

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:29.0) Gecko/20100101 Firefox/29.0 (Beta/Release)
Build ID: 20140114030236

Steps to reproduce:

1. Add an oninput event handler which produces an alert to a number/range input.
2. Alter the number/range input with the mouse (with the keyboard it works well).


Actual results:

The alert is shown, but current window becomes frozen until it loses focus.


Expected results:

Current window shouldn't become frozen.

Comment 1

4 years ago
no alert: 2013-03-17-03-09-23-mozilla-central-firefox-22.0a1.en-US.linux-x86_64 0b052daa913c
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=0b052daa913c&tochange=b03bb3ce8cee  bug 851090
can be closed with many clicks: 2013-03-18-03-09-47-mozilla-central-firefox-22.0a1.en-US.linux-x86_64 b03bb3ce8cee
can be closed with many clicks: 2013-12-17-08-47-57-mozilla-central-firefox-29.0a1.en-US.linux-x86_64 d58545aaeab9
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=d58545aaeab9&tochange=862cb6a1cc88
cannot be closed with a click: 2013-12-18-03-02-17-mozilla-central-firefox-29.0a1.en-US.linux-x86_64 862cb6a1cc88
cannot be closed with a click: 2014-01-15-03-02-29-mozilla-central-firefox-29.0a1.en-US.linux-x86_64
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Summary: Alert in oninput of number/range freezes window → Alert in oninput of number/range freezes window, cannot be closed with mouse
Whiteboard: [bugday-20140115]

Comment 2

4 years ago
(In reply to [:Aleksej] from comment #1)
> can be closed with many clicks:

That actually seems to be reopening of the alert, as a checkbox to block it appears on subsequent clicks.
Component: Untriaged → General
Summary: Alert in oninput of number/range freezes window, cannot be closed with mouse → Alert in oninput of number/range freezes window, cannot be closed with mouse clicks
(Reporter)

Comment 3

4 years ago
It seems some update fixed it, because I can't reproduce it anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME

Comment 4

4 years ago
Confirmed that it can be closed with 2014-02-03-03-02-03-mozilla-central-firefox-29.0a1.en-US.linux-x86_64.

But I guess something is still wrong: when after closing the alert, I move the pointer back to the range input, another alert opens, and the input is reset to the middle.  The second alert can be closed w/o consequences.
(Reporter)

Comment 5

4 years ago
True, with my current profile I didn't have that problem, but I can reproduce it with a clean one.

Moreover, the alert fires even if the range value doesn't change (just clicking at the current position). Since it's an onchange event handler, I don't think it should fire (on Chrome it doesn't).

Should this bug be reopened, or a new one created?
Flags: needinfo?(deletesoftware+moz)

Comment 6

4 years ago
can't close: 20140129030602 1390993562-mozilla-central-firefox-29.0a1.en-US.linux-x86_64 7e79536aca0a
current behaviour: 20140129121012 1391026212-mozilla-central-firefox-29.0a1.en-US.linux-x86_64 27c8e496895a

https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=7e79536aca0a&tochange=27c8e496895a

(inbound — I was confused when I tested these builds, because mozregression said it was downloading them; not sure they are actually relevant:
can't close: 20140126043545 1390739745-mozilla-inbound-firefox-29.0a1.en-US.linux-x86_64 99c61f40109b
current behaviour: 20140129003001 1390984201-mozilla-inbound-firefox-29.0a1.en-US.linux-x86_64 f45d7708826f
current behaviour: 20140129064835 1391006915-mozilla-inbound-firefox-29.0a1.en-US.linux-x86_64 0c8fa25eafe9)
Flags: needinfo?(deletesoftware+moz)

Comment 7

4 years ago
inbound was relevant, but getting the list times out: https://github.com/mozilla/mozregression/issues/77

can't close: ebaa4b58e71c 1390952592-mozilla-inbound-firefox-29.0a1.en-US.linux-x86_64
current behaviour: d7a6a64b42f0 1390957633-mozilla-inbound-firefox-29.0a1.en-US.linux-x86_64

https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ebaa4b58e71c&tochange=d7a6a64b42f0

Comment 8

4 years ago
I don't know.
Status: RESOLVED → REOPENED
Component: General → Layout: Form Controls
Product: Firefox → Core
Resolution: WORKSFORME → ---
You need to log in before you can comment on or make changes to this bug.