TransitionEvent and AnimationEvent should not be cancelable

RESOLVED FIXED in mozilla29

Status

()

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: dbaron, Assigned: dbaron)

Tracking

Trunk
mozilla29
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Per recent changes to the CSS transitions spec and somewhat older (I think) changes to the CSS animations spec, TransitionEvent and AnimationEvent should not be cancelable.

http://lists.w3.org/Archives/Public/www-style/2014Jan/0091.html has the transitions spec change links.

Patch coming shortly (once I test the tests).
Created attachment 8360055 [details] [diff] [review]
patch 1: Fix tests in test_eventctors.html that weren't testing what was intended.
Attachment #8360055 - Flags: review?(bugs)
Created attachment 8360056 [details] [diff] [review]
patch 2: Transition events and animation events are not cancelable.
Attachment #8360056 - Flags: review?(bugs)

Comment 3

5 years ago
Comment on attachment 8360055 [details] [diff] [review]
patch 1: Fix tests in test_eventctors.html that weren't testing what was intended.

Oops
Attachment #8360055 - Flags: review?(bugs) → review+

Updated

5 years ago
Attachment #8360056 - Flags: review?(bugs) → review+

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/2d28685614ff
https://hg.mozilla.org/mozilla-central/rev/7630be99a9d1
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29

Comment 6

5 years ago
Updating flags per tests here
> https://hg.mozilla.org/mozilla-central/rev/2d28685614ff
> https://hg.mozilla.org/mozilla-central/rev/7630be99a9d1
Flags: in-testsuite+
You need to log in before you can comment on or make changes to this bug.