Closed Bug 959866 Opened 10 years ago Closed 10 years ago

[B2G][Gallery] Double tapping on toolbar, zooms in UI

Categories

(Firefox OS Graveyard :: Gaia::Gallery, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v1.2 unaffected, b2g-v1.3 affected)

RESOLVED DUPLICATE of bug 957790
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- affected

People

(Reporter: pbylenga, Unassigned)

Details

(Keywords: regression, Whiteboard: dogfood1.3)

Attachments

(2 files)

Description:
When in Gallery App viewing in list view or in edit mode, double tapping on the toolbar zooms in on the ui.  Double tapping again goes back to normal view.  Issue reproduces both with and without APZ enabled.

Pre-requisites:
Have a few pictures available in Gallery App.

Repro Steps:
1) Updated Buri to Build ID: 20140113004002
2) Launch Gallery App
3) Double tap on toolbar and observe

Actual:
View is zoomed in on the toolbar UI

Expected:
Nothing happens, zoom is not supported in list/edit view

Environmental Variables
Device: Buri v1.3 Mozilla RIL
Build ID: 20140113004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5bb1837de7c0
Gaia: b3fc4f712562ee92b0ed0bd17abc61be9a36a8da
Platform Version: 28.0a2
Firmware Version: v1.2-device

Notes:
Repro frequency: 5/5, 100%
See attached: logcat
Issue does not reproduce in v1.2

Environmental Variables:
Device: Buri 1.2 COM
BuildID: 20140113004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: e672faf1e6a1
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2-device.cfg
Whiteboard: dogfood1.3
Attached image Gallery_UI_ZoomedIn.png
Adding screenshot, showing issue after zooming in.  Note it's zoomed in to the point that the share button is out of view.  In this zoom mode you can pan around as well.
Confusing UX regression. Probably want to get this fixed.
blocking-b2g: --- → 1.3?
Peter,

Do you kill the app and restart it when you disable APZ or enable APZ? I met a problem related with APZ before. We may need to kill the app and restart it to have APZ change affected.
Flags: needinfo?(pbylenga)
This is a strange issue.

There are two cases that this bug cannot be reproduced anymore:
1. rotate the phone to landscape and back to portrait, this issue is gone.
2. disable APZ and restart the app, this issue is gone.
The zoom in/out of a web app can be disabled with the "user-scalable=no" in viewport of meta tag. I can confirm that the user-scalable=no was added since bug 916185 which is land at November 2013 and no one changed it.


A related bug may be found at bug 956786. But that is not reproduced at 1.4(master) now.
It is possible that it was a duplicate of bug 957790 and that the build you have tried on missed the patch that has landed on the 13 ?

Can you recheck ?
Bug 957790 was not tagged as 1.3+, so it was never uplifted.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
John,

I can confirm your findings in Comment 5 when I kill the app after toggling APZ.  

I also can reproduce the issue with the Twitter App on the top header portion, so it's not limited to Gallery App.
Flags: needinfo?(pbylenga)
No longer blocks: gaia-apzc
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: