Creating marionette docs locally is not intuitive

RESOLVED DUPLICATE of bug 1384517

Status

Testing
Marionette
RESOLVED DUPLICATE of bug 1384517
4 years ago
9 months ago

People

(Reporter: wlach, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [marionette-docs])

Noticed this problem with bug 956803.

To generate the marionette docs, you need to generate a virtualenv *and* install sphinx inside of it (or set the SPHINXBUILD environment variable to point to the virtualenv: http://stackoverflow.com/a/4249730/295132). This isn't documented anywhere, we should generate a simple README or something inside the marionette/docs directory so it's easier for people to generate a local copy of the docs.
Whiteboard: [marionette-docs]
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1384517
You need to log in before you can comment on or make changes to this bug.