Closed Bug 959990 Opened 6 years ago Closed 6 years ago

Add preferences for Firefox Account ToS and Privacy Policy, and have utility functions use them if appropriate

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
mozilla29

People

(Reporter: markh, Assigned: markh)

References

Details

(Whiteboard: [qa!])

Attachments

(1 file, 2 obsolete files)

The sync options dialog when Fxa is enabled will have TOS and PP links, which should open the Fxa specific policies.  This patch adds preferences for these links, and changes the utility functions to use them when appropriate
Attachment #8360295 - Flags: feedback?(rnewman)
Attachment #8360295 - Flags: feedback?(ckarlof)
Whiteboard: [qa+]
Assignee: nobody → mhammond
Status: NEW → ASSIGNED
Summary: Add preferences for Fxa TOS and Privacy Policy, and have utility functions use them if appropriate → Add preferences for Firefox Account ToS and Privacy Policy, and have utility functions use them if appropriate
Comment on attachment 8360295 [details] [diff] [review]
0001-Add-fxa-specific-TOS-and-PP-prefs-and-have-utils-fun.patch

Review of attachment 8360295 [details] [diff] [review]:
-----------------------------------------------------------------

I'm assuming that that boolean flag is set when we're using FxA!

::: browser/base/content/sync/utils.js
@@ +16,5 @@
>  
> +  get fxAccountsEnabled() {
> +    let service = Components.classes["@mozilla.org/weave/service;1"]
> +                                .getService(Components.interfaces.nsISupports)
> +                                .wrappedJSObject;

Nit: align the dots, and use Cc and Ci if they're defined.
Attachment #8360295 - Flags: feedback?(rnewman) → review+
Comment on attachment 8360295 [details] [diff] [review]
0001-Add-fxa-specific-TOS-and-PP-prefs-and-have-utils-fun.patch

Review of attachment 8360295 [details] [diff] [review]:
-----------------------------------------------------------------

::: services/sync/services-sync.js
@@ +74,5 @@
>  
>  pref("services.sync.tokenServerURI", "http://auth.oldsync.dev.lcip.org/1.0/sync/1.1");
> +
> +pref("services.sync.fxa.termsURL", "https://accounts.dev.lcip.org/tos");
> +pref("services.sync.fxa.privacyURL", "https://accounts.dev.lcip.org/pp");

I've been working with Legal on this, and I'm not sure if we're going to have separate TOS and PP pages. Urmika is working on a more unified approach. Also, these will most likely not live on our FxA server, but in a more centralized location on the Mozilla web site.
Attachment #8360295 - Flags: feedback?(ckarlof) → feedback+
(In reply to Richard Newman [:rnewman] from comment #1)
> Comment on attachment 8360295 [details] [diff] [review]
> 0001-Add-fxa-specific-TOS-and-PP-prefs-and-have-utils-fun.patch
> 
> Review of attachment 8360295 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> I'm assuming that that boolean flag is set when we're using FxA!

Correct - it will only be false if we've determined we are configured for a legacy provider.

> Nit: align the dots,

Done.

> and use Cc and Ci if they're defined.

They aren't (and I didn't bother adding them for this)

Carrying r+ forward, but I will not land this until we get clarification from Chris on whether multiple links and the links themselves make sense.
Attachment #8360295 - Attachment is obsolete: true
Attachment #8361581 - Flags: review+
Comment on attachment 8361581 [details] [diff] [review]
0001-Bug-959990-Add-fxa-specific-TOS-and-PP-prefs-and-hav.patch

Review of attachment 8361581 [details] [diff] [review]:
-----------------------------------------------------------------

This looks fine for now. I don't have further insight on the one vs two url approach and we still waiting for info on this in about:accounts too. I'll try to get some info on this next week. Let's land it.

::: services/sync/services-sync.js
@@ +74,5 @@
>  
>  pref("services.sync.tokenServerURI", "http://auth.oldsync.dev.lcip.org/1.0/sync/1.1");
> +
> +pref("services.sync.fxa.termsURL", "https://accounts.dev.lcip.org/tos");
> +pref("services.sync.fxa.privacyURL", "https://accounts.dev.lcip.org/pp");

We need prod versions of these urls in bug 960332.
For both the ToS and PN, please use: https://accounts.firefox.com for now. I'm copying and pasting Mark Mayo's comment on this in a separate discussion on the URL for where's my fox in Bug 951798 (comment 11).

"Web flows for users accessing Accounts will use https://accounts.firefox.com. Our unified ToS and privacy statement will likely live there as well, at least for now.

While we have the larger branding discussions about what, if anything, we call the set of Firefox online services (aka "cloud") I'd suggest the primary thing to decide right now is what we're calling this particular feature. I feel pretty strongly that the web component should live *somewhere* under firefox.com, but where exactly (a subdomain or a /xxx) we can decide later."
At the moment we have 2 fields, labelled "Terms Of Service" and "Privacy Policy".  What should the text say for this one unified field - simply "Terms Of Service and Privacy Policy"?  Or maybe it's OK to stick with 2 fields going to the same place?

I ask as these are strings that need to be localized, so we should try and nail them down ASAP with the understanding that it might be difficult to change once 29 branches.
Flags: needinfo?(udevi)
(In reply to Mark Hammond [:markh] from comment #6)
> At the moment we have 2 fields, labelled "Terms Of Service" and "Privacy
> Policy".  What should the text say for this one unified field - simply
> "Terms Of Service and Privacy Policy"?  Or maybe it's OK to stick with 2
> fields going to the same place?
> 
> I ask as these are strings that need to be localized, so we should try and
> nail them down ASAP with the understanding that it might be difficult to
> change once 29 branches.

By "fields" do you mean links? There should be two separate links for "Terms of Service" and "Privacy Notice".
Flags: needinfo?(udevi)
On Android, I'm sticking with two links, but both go to the same place. That way we can tweak the URLs as needed without me changing much.

<!ENTITY fxaccount.link.tos 'https://accounts.firefox.com/'>
<!ENTITY fxaccount.policy.2 'By proceeding you agree with the &lt;a
         href="&fxaccount.link.tos;"&gt;Terms of Service&lt;/a&gt; and &lt;a
         href="&fxaccount.link.tos;"&gt;Privacy Policy&lt;/a&gt;.'>
Please make sure to say Privacy "Notice" in any user facing copy (and not the word "Policy")

The reason is that we've changed our legal documentation so there is a short privacy "notice" that is very user friendly and specific about data.  For users who want to read more, the longer "Mozilla Privacy Policy" will be included as a link within the text of the short notice. 

Thanks!
Depends on: 963872
(In reply to Mika from comment #9)
> Please make sure to say Privacy "Notice" in any user facing copy (and not
> the word "Policy")

Done.

Filed Bug 963872 to clarify the fact that accounts.firefox.com is a setup wizard, not TOS/PP.
This patch uses "https://accounts.firefox.com/" - but I'll defer landing pending the outcome of bug 963872.  Bug 957426 will ensure the user-facing text is "Privacy Notice"
Attachment #8361581 - Attachment is obsolete: true
Attachment #8365438 - Flags: review+
Outcome:

/legal/terms
/legal/privacy
Duplicate of this bug: 964882
https://hg.mozilla.org/mozilla-central/rev/4200badb7d4b
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Verified as fixed using the following environment:

FF 29.0b8
Build Id: 20140414143035
OS: Win 7 x64, Mac Os x 10.9.2, Ubuntu 13.04 x 64

The "Terms of Service" link under Sync Options(Preferences) opens https://accounts.firefox.com/en-US/legal/terms page.
The "Privacy Notice" link under Sync Options(Preferences) opens https://accounts.firefox.com/en-US/legal/privacy
Status: RESOLVED → VERIFIED
Whiteboard: [qa+] → [qa!]
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.