Closed Bug 960051 Opened 6 years ago Closed 6 years ago

Update pdf.js to version 0.8.934

Categories

(Firefox :: PDF Viewer, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 29

People

(Reporter: RyanVM, Assigned: RyanVM)

References

Details

Attachments

(1 file, 4 obsolete files)

+++ This bug was initially created as a clone of Bug #947260 +++

Changes since the last update:
#4007 Dutch translations for the hand tool
#4008 Add hand tool strings to the Swedish l10n
#4013 Hand tool translations for zh-TW
#4018 Update L10n for DE
#4020 Prevent the page number field from having a spinner (spin buttons) in mozilla now that mozilla supports <input type=number>
#4024 Update viewer.properties in l10n for zh-CN
#4032 Update zh-TW again based on latest strings.
#4033 Fix typo in viewer.css
#4037 Update ja locale
#4038 Add unprefixed "grab" / "grabbing" values for cursor
#4040 Correct a typo in `getJavaScript` function expression name.
#3967 Add support for horizontal scrolling in 'scrollIntoView' in ui_utils.js
#4006 [CRX] Add a pageAction to omnibox showing PDF URL
#3997 Fix loading of fonts that are not referenced by an object identifier
#4043 Small cleanup in 'set page'
#4003 [JBIG2] Fix getting decodeParms when it's an array
#4025 Add singlefile build target
#4050 Fix typo in 'isViewFinished' function name
#4065 Remove superfluous <!DOCTYPE html> from page action
#4059 add support for Conkeror
#4066 Added missing <html> tag to page action
#4053 Rename 'Settings' to 'ViewHistory'
#4055 Fix thumbnail rotation regression
#4058 Fix singlefile build target
#4045 Add verbosity as an api setting.
#4001 Clean up test PDF references
#4067 Recompressed PNG assets
#4048 Only trigger warning bar on certain unsupported features.
#4075 Update Spanish translation
#4060 Introduces LegacyPromise; polyfills DOM Promise
#4011 Set eof to true at the end of a FlateStream
#4062 calgray: fix getRgbBuffer problem
#4087 Label ref test analyzer images.
#4077 Show a different warning for PDF's with forms.
#4092 Add forms warning to the Swedish l10n
#4034 Fix setScale regression that affects exiting Presentation Mode on narrow window widths
#4068 Adjusts heuristic for disabling Symbol encoding
#4071 Adds glyph mapping for standard fonts
#4088 Allow hand tool toggle button to be optional
#4094 Fix reftest analyzer naming(again).
#4095 Add forms warning to the Dutch l10n
#4097 Add form warning and minor translation update for zh-TW
#4080 Fix annotation border issue (bug 957034)
#4099 Fixes FitV scrolling
#4074 Maintain the current position in the document when zooming
#4109 Update the annotationLayer when using CSS only zoom
#4116 Move the Swedish l10n
#4117 Make presentation mode use a black background
#4114 Update chrome.tabs.executeScriptInFrame dependency
#4120 De-inline CSS for the 'open file' button
#4121 Prevent the open file button from appearing in the B2G viewer/preview
#4122 Use a more compact typed array to pass the image mask from the worker
Attached patch Update pdf.js to version 0.8.870 (obsolete) — Splinter Review
IIRC, Mossop wants to r? changes to PdfStreamConverter.js ?
Attachment #8360403 - Flags: review?(dtownsend+bugmail)
Attachment #8360403 - Flags: review?(bdahl)
Attachment #8360403 - Flags: review?(dtownsend+bugmail) → review+
Blocks: 959925
Now that PR4139 has been merged, should I go ahead and update the patch, or should I wait for the rest of the work in bug 959925 to wrap up first?
Flags: needinfo?(n.nethercote)
> Now that PR4139 has been merged, should I go ahead and update the patch, or
> should I wait for the rest of the work in bug 959925 to wrap up first?

Please update! The remaining issue is much harder to fix and is unlikely to happen soon.
Flags: needinfo?(n.nethercote)
Changes since the last update:
#4081 Avoiding double draw() calls
#4124 Allow setting xhr.withCredentials
#4128 Fix regression that disabled the "Open With Different Viewer" button on the fallback bar
#4103 Introduces disableObjectCreateURL
#4125 Fixes and refactors log functionality
#4089 Takes ascent/descent in account in the text layer
#4093 Fixes fips regression from #4068
#4119 Extracts evaluator preprocessor, refactor text extraction and paintFormXObject
#4142 Remove old CSS rules
#4138 Do createImageData/putImageData in chunks, to save memory.
#4136 Removing extension-files file
#4135 Cleaning up files in extension
#4072 Checks if subpixel-aa enabled before scaling the fonts
#4153 4027 - Terminate worker of previous doc
#4147 Fix loading of fonts with invalid encoding name entry (bug 859204 and 878112)
#4139 Write color and opacity values directly to the final RGBA array when possible, so as to avoid allocating unnecessary memory.
#4144 Misc fixes for the API docs
#4140 Close the secondary toolbar when an action is performed once
#4154 RTL CSS improvements
#4158 Fixes this.reject regression
#4149 Document properties
Summary: Update pdf.js to version 0.8.870 → Update pdf.js to version 0.8.907
Attached patch Update pdf.js to version 0.8.907 (obsolete) — Splinter Review
Attachment #8360403 - Attachment is obsolete: true
Attachment #8360403 - Flags: review?(bdahl)
Attachment #8363348 - Flags: review?(bdahl)
Summary: Update pdf.js to version 0.8.907 → Update pdf.js to version 0.8.913
Attached patch Update pdf.js to version 0.8.913 (obsolete) — Splinter Review
I hit some issues with the mozcentral.diff generated by the pdf.js build system, so I basically rebuilt things from scratch.

One really important thing - it appears that mochitest manifest conversion (Makefile.in -> browser.ini) never got upstreamed. I manually fixed things up for this patch, but that really needs doing.
Attachment #8363348 - Attachment is obsolete: true
Attachment #8363348 - Flags: review?(bdahl)
Attachment #8363363 - Flags: review?(bdahl)
Flags: needinfo?(ydelendik)
Attached patch Update pdf.js to version 0.8.913 (obsolete) — Splinter Review
Lovely, browser_pdfjs_views.js from bug 862217 never got upstreamed either. Re-added.

Try run: https://tbpl.mozilla.org/?tree=Try&rev=03566af3dc59
Attachment #8363363 - Attachment is obsolete: true
Attachment #8363363 - Flags: review?(bdahl)
Attachment #8363371 - Flags: review?(bdahl)
Comment on attachment 8363371 [details] [diff] [review]
Update pdf.js to version 0.8.913

Yury, can you give this a looking-over too please?
Attachment #8363371 - Flags: review?(ydelendik)
Comment on attachment 8363371 [details] [diff] [review]
Update pdf.js to version 0.8.913

Review of attachment 8363371 [details] [diff] [review]:
-----------------------------------------------------------------

The modification of the browser/extensions/pdfjs/test/file_pdfjs_test.pdf shall not be a part of this patch. Otherwise is good. r+ without file_pdfjs_test.pdf modification.
Attachment #8363371 - Flags: review?(ydelendik) → review+
(In reply to Yury Delendik (:yury) from comment #10)
> The modification of the browser/extensions/pdfjs/test/file_pdfjs_test.pdf
> shall not be a part of this patch. Otherwise is good. r+ without
> file_pdfjs_test.pdf modification.

Any idea why it changed?
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #6)
> One really important thing - it appears that mochitest manifest conversion
> (Makefile.in -> browser.ini) never got upstreamed. I manually fixed things
> up for this patch, but that really needs doing.

FF browser tests are out of sync between pdf.js upstream and m-c atm. We will look into that https://github.com/mozilla/pdf.js/issues/4165
Flags: needinfo?(ydelendik)
Ryan, if it's easy, could you add couple of more pull requests to this patch. https://github.com/mozilla/pdf.js/pull/4167 contains some localization logic and strings fixes.
Flags: needinfo?(ryanvm)
Changes since the last update:
#4126 Chromium extension using streamsPrivate API!
#4160 Document Propeties translation in zh-TW
#4163 Recover from bad URI values
#4164 Only check for line dash pattern when annotation has a visible border (bug 957034 followup)
#4167 Miscellaneous improvements for the document properties dialog
#4168 Update fr locale
#4169 zh-TW translation update for document properties
#4170 Add Document Properties to the Swedish l10n
Flags: needinfo?(ryanvm)
Summary: Update pdf.js to version 0.8.913 → Update pdf.js to version 0.8.934
Removes the changes to file_pdfjs_test.pdf per Yury's comments as well.
Attachment #8363371 - Attachment is obsolete: true
Attachment #8363371 - Flags: review?(bdahl)
Attachment #8364362 - Flags: review?(bdahl)
Attachment #8364362 - Flags: review?(bdahl) → review+
Backed out in https://hg.mozilla.org/integration/fx-team/rev/0e17908f897f because either this or bug 962736 (or much less likely one of the other patches Ryan pushed with them) permanently broke xperf tests on Win7:
https://tbpl.mozilla.org/php/getParsedLog.php?id=33488315&tree=Fx-Team
Whiteboard: [fixed-in-fx-team]
The backout went green, so it was one of these two patches that broke it.
(In reply to Till Schneidereit [:till] from bug 962736 comment #10)
> In that case, my money is on bug 960051: it has password prompting-related
> changes, so changed patterns of key storage accesses seem to make sense.

We'll see if Try agrees.
https://tbpl.mozilla.org/?tree=Try&rev=4a7c077a1862
It was the Shumway update.
https://hg.mozilla.org/integration/fx-team/rev/7c5e60cbcc95
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/7c5e60cbcc95
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Starting with the 1/25 nightly, Opening a PDF results in a loop on blank browser windows (at least on OSX) until the user force quits Firefox.
(In reply to David Filiatrault from comment #22)
> Starting with the 1/25 nightly, Opening a PDF results in a loop on blank
> browser windows (at least on OSX) until the user force quits Firefox.

David,

It works for me for opening PDFs on the web and from local drive. Try creating a new profile. If this does not help, open a new issue with details and steps to replicate.
Ok, figured out that my Comment #22 was caused by me inadvertently changing the preference for loading PDF documents from "Preview in Firefox" to "Use FirefoxNightly".  Once I returned the preference to it's default setting, normal behavior returned.  Problem between keyboard and chair...
Blocks: 965861
Blocks: 957034
Blocks: 859204
You need to log in before you can comment on or make changes to this bug.