Closed Bug 960095 Opened 6 years ago Closed 6 years ago

saveStyleSheet.title entity appears 3 times in browser/devtools/styleeditor.properties

Categories

(DevTools :: Style Editor, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 29

People

(Reporter: flod, Assigned: harth)

References

Details

Attachments

(1 file)

I don't know what happened, as the patch attached to bug 950921 doesn't add any saveStyleSheet.title entities. Maybe a landing issue?

Those keys will clash.
I'm looking at the patch and see the string twice, plus one already existing, so I think the problem is not with the landing.
Forgive me, I was looking at the wrong properties file.

This takes the two extra title strings out, and changes the access key to a unique one. I didn't change the string name because this hasn't made it to Aurora yet, but let me know if I should change it regardless.
Assignee: nobody → fayearthur
Attachment #8360774 - Flags: review?(dcamp)
In general you need to change the string ID if the string has already landed on mozilla-central, and therefore exposed to the localization process.

Access keys don't really need that, consider that each locale has different labels, so this kind of change is OK. I'll send a message to dev-l10n to notify them of the change, just to stay on the safe side.

The same string+ak is used in browser/devtools, no idea what other commands are displayed together and if there are more conflicts (haven't seen the menu yet).
Duplicate of this bug: 960013
Can we get traction on this bug? Should be an easy fix and we're not far away from merge day.
Attachment #8360774 - Flags: review?(dcamp) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/6dc4806fa8a2
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.