Window size and position not saved

VERIFIED DUPLICATE of bug 96009

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 96009
16 years ago
13 years ago

People

(Reporter: elemental, Assigned: Paul Chen)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080110

Opening multiple (non-maximized) windows causes Mozilla to forget original
window size and position.

Reproducible: Always
Steps to Reproduce:
1. Open any web page (say, threaded Slashdot comments, for example).
2. Open comment URL in new window.
3. Open a comment URL off that child window in another new window.
4. Close both child windows.
5. Open another window from original page.

Actual Results:  The window in step 5 will open in the position of the window in
step 3, not 2.

Expected Results:  IMO, new windows in Mozilla, whether they're opened from the
File menu or by right clicking and opening link in new window, should behave the
way they do in Netscape 4.x. That is, the size should be the same as the parent
window and the location of the child window should be the same every time,
slightly offset from it's parent.

This is relative though, as a child of a child should be slightly offset from
the position of it's immediate parent, not the original window. Does that make
any sense?

Further, closing all open windows after multiple windows have been open causes
the first window in a new instance of Mozilla to use the size/position of one of
the previous child windows. This new instance should inherit the size/position
of the last window closed in the previous instance.
(Reporter)

Comment 1

16 years ago

*** This bug has been marked as a duplicate of 96009 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.