WebRTC is not connected with WebAudio

RESOLVED DUPLICATE of bug 1070127

Status

()

Core
WebRTC: Audio/Video
RESOLVED DUPLICATE of bug 1070127
4 years ago
3 years ago

People

(Reporter: Alexey, Unassigned)

Tracking

26 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.77 Safari/537.36

Steps to reproduce:

Sending audio stream from PeerConnection to WebAudio for mixing and sending it back to PeerConnection:

getUserMedia.call(navigator, options, function(stream) {
	// get the stream,  wrap it using AudioContext then get if from 
	var src = ac.createMediaStreamSource(stream);
	var peer = ac.createMediaStreamDestination();
	src.connect(peer);
	// send it to PeerConnection by providing AddStream with peer.stream input
}, …


Actual results:

No sound on the other end of the PeerConnection


Expected results:

Sound from microphone from one end of the PeerConnection should be heard on the other end of the PeerConnection

Updated

4 years ago
Component: Untriaged → WebRTC: Audio/Video
Product: Firefox → Core

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1070127
You need to log in before you can comment on or make changes to this bug.