[B2G][Contacts] "Unable to connect" debug text appears in the Contacts app after importing contacts from Facebook

RESOLVED DUPLICATE of bug 959414

Status

Firefox OS
Gaia::Contacts
RESOLVED DUPLICATE of bug 959414
5 years ago
5 years ago

People

(Reporter: KTucker, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-2)

Attachments

(2 attachments)

Created attachment 8360576 [details]
UnabletoconnectFacebook.txt

Description:
"Unable to connect" debug text appears in the Contacts app after importing contacts from Facebook. This will be seen at the bottom half of the screen after the keyboard disappears when adding a contact. It also appears when performing a search for contacts and then tapping "cancel". 

Repro Steps:
1)  Updated Buri to Build ID: 20140115004003
2)  Tap on the "Contacts" app.
3)  Tap on the "Settings" icon.
4)  Tap on the "Sync friends" Facebook toggle.
5)  Log into Facebook and tap on "Select all" to select the Facebook contacts.
6)  Tap on "Import". 
7)  After the contacts have been imported, tap on the "+" icon to manually add a contact.
8)  Enter a name into the "Name" field and then tap the "X" button to close the "Add contact" page. Pay close attention to the bottom of the screen.

Actual:
"Unable to connect" debug text appears at the bottom of the screen. 

Expected:
Debug text does not appear after the keyboard closes in the Contacts app. 

Environmental Variables
Device: Buri v 1.3.0 Mozilla RIL
Build ID: 20140115004003
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/d7260b206e91
Gaia: 14e199d6a9ad917eacad883820a9f7619dbf42c8
Platform Version: 28.0a2

Notes:
Repro frequency: 100%
Link to failed test case:
See attached: video clip, logcat
This issue does not occur on the Buri v 1.2.0 Mozilla RIL

Environmental Variables
Device: Buri v 1.2.0 Mozilla RIL
Build ID: 20140114004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/42a1c35fc831
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0

Debug text is not seen at the bottom of the screen in the Contacts app after importing contacts from Facebook.
Created attachment 8360583 [details]
UnabletoconnectFacebookvideo.mp4

Comment 4

5 years ago
Discussed with Kevin for validation.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 959414

Updated

5 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.