[PRINT TABLES CRASH]print causes crash

VERIFIED DUPLICATE of bug 95420

Status

()

Core
Printing: Output
--
critical
VERIFIED DUPLICATE of bug 95420
17 years ago
17 years ago

People

(Reporter: Sean Moore, Assigned: karnaze (gone))

Tracking

({qawanted})

Trunk
x86
Windows 2000
qawanted
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
using 8/17 nightly build.
open the referenced url in browser and "file - print" - causes crash.
I will submit talkback data later but talkback.netscape.com is down.

Comment 1

17 years ago
I can reproduce this crash. 

talkback ID = 34270701

Comment 2

17 years ago
I can reproduce this bug.. the stacktrace is the following:
Assigning to tables..

nsTableRowGroupFrame::InitRepeatedFrame(nsIPresContext * 0x05529600, 
nsTableRowGroupFrame * 0x0466dcf4) line 149 + 3 bytes
nsCSSFrameConstructor::CreateContinuingTableFrame(nsIPresShell * 0x0552abf0, 
nsIPresContext * 0x05529600, nsIFrame * 0x0466dc8c, nsIFrame * 0x047a8cbc, 
nsIContent * 0x044ee490, nsIStyleContext * 0x047ebe8c, nsIFrame * * 0x00129844) 
line 10861
nsCSSFrameConstructor::CreateContinuingFrame(nsCSSFrameConstructor * const 
0x0552afc0, nsIPresShell * 0x0552abf0, nsIPresContext * 0x05529600, nsIFrame * 
0x0466dc8c, nsIFrame * 0x047a8cbc, nsIFrame * * 0x00129950) line 10952 + 36 
bytes
nsCSSFrameConstructor::CreateContinuingOuterTableFrame(nsIPresShell * 
0x0552abf0, nsIPresContext * 0x05529600, nsIFrame * 0x0466dc40, nsIFrame * 
0x0466d7e4, nsIContent * 0x044ee490, nsIStyleContext * 0x047ebfd0, nsIFrame * * 
0x001299b8) line 10752
nsCSSFrameConstructor::CreateContinuingFrame(nsCSSFrameConstructor * const 
0x0552afc0, nsIPresShell * 0x0552abf0, nsIPresContext * 0x05529600, nsIFrame * 
0x0466dc40, nsIFrame * 0x0466d7e4, nsIFrame * * 0x00129a14) line 10948 + 36 
bytes
StyleSetImpl::CreateContinuingFrame(StyleSetImpl * const 0x055290d0, 
nsIPresContext * 0x05529600, nsIFrame * 0x0466dc40, nsIFrame * 0x0466d7e4, 
nsIFrame * * 0x00129a14) line 1275 + 43 bytes
nsHTMLContainerFrame::CreateNextInFlow(nsIPresContext * 0x05529600, nsIFrame * 
0x0466d7e4, nsIFrame * 0x0466dc40, nsIFrame * & 0x00000000) line 152
nsBlockFrame::CreateContinuationFor(nsBlockReflowState & {...}, nsLineBox * 
0x046ce400, nsIFrame * 0x0466dc40, int & 0) line 3627 + 24 bytes
nsBlockFrame::ReflowBlockFrame(nsBlockReflowState & {...}, nsLineBox * 
0x046ce400, int * 0x00129e20) line 3021 + 42 bytes
nsBlockFrame::ReflowLine(nsBlockReflowState & {...}, nsLineBox * 0x046ce400, int 
* 0x00129e20, int 0) line 2240 + 23 bytes
nsBlockFrame::ReflowDirtyLines(nsBlockReflowState & {...}) line 2048 + 27 bytes
nsBlockFrame::Reflow(nsBlockFrame * const 0x0466d7e4, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 797 + 15 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0466d7e4, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
15, int 15, unsigned int 0, unsigned int & 0) line 726 + 31 bytes
nsTableCellFrame::Reflow(nsTableCellFrame * const 0x0466dbe4, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 756
nsContainerFrame::ReflowChild(nsIFrame * 0x0466dbe4, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 
30, int 0, unsigned int 0, unsigned int & 0) line 726 + 31 bytes
nsTableRowFrame::ReflowChildren(nsTableRowFrame * const 0x0466d798, 
nsIPresContext * 0x05529600, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, nsTableFrame & {...}, unsigned int & 0, int 0) line 
880 + 45 bytes
nsTableRowFrame::Reflow(nsTableRowFrame * const 0x0466d798, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, 
unsigned int & 0) line 1246 + 37 bytes
nsContainerFrame::ReflowChild(nsIFrame * 0x0466d798, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 0, unsigned int 3, unsigned int & 0) line 726 + 31 bytes
nsTableRowGroupFrame::SplitRowGroup(nsIPresContext * 0x05529600, 
nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, nsTableFrame * 
0x0466db40, unsigned int & 0) line 941 + 43 bytes
nsTableRowGroupFrame::Reflow(nsTableRowGroupFrame * const 0x0466dba8, 
nsIPresContext * 0x05529600, nsHTMLReflowMetrics & {...}, const 
nsHTMLReflowState & {...}, unsigned int & 0) line 1075
nsContainerFrame::ReflowChild(nsIFrame * 0x0466dba8, nsIPresContext * 
0x05529600, nsHTMLReflowMetrics & {...}, const nsHTMLReflowState & {...}, int 0, 
int 30, unsigned int 0, unsigned int & 0) line 726 + 31 bytes
nsTableFrame::ReflowChildren(nsTableFrame * const 0x0466db40, nsIPresContext * 
0x05529600, nsTableReflowState & {...}, int 1, int 0, unsigned int & 0, int * 
0x00000000) line 3046 + 47 bytes
nsTableFrame::ReflowTable(nsIPresContext * 0x05529600, nsHTMLReflowMetrics & 
{...}, const nsHTMLReflowState & {...}, int 346, nsReflowReason 
eReflowReason_Resize, int & 0, int & 1, unsigned int & 0) line 2014



Assignee: dcone → karnaze
Summary: print causes crash → [PRINT TABLES CRASH]print causes crash
(Assignee)

Comment 3

17 years ago
I need a reduced test case.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Keywords: qawanted
(Reporter)

Comment 4

17 years ago
it is hard to trim it down to a shorter case because I am pretty sure
it has to do with the nested tables and them printing across page
breaks.  If you change anything you change how the tables fall across the
page breaks and no crash. I have shortened the source reported url table by 
table up to where it still crashes so maybe the crash is on the last table.
Hope that helps and sorry for the non trivial test case but I dont
think it is that simple but it is common.

Comment 5

17 years ago
related to bug 95420?

Comment 6

17 years ago

*** This bug has been marked as a duplicate of 95420 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 7

17 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.