Avoid "aTab is null" error with <iframe mozbrowser>

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: billm, Assigned: billm)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Created attachment 8360612 [details] [diff] [review]
tab-null-fix

I was debugging some stuff in the dom/browser-element code today and I get a ton of "aTab is null" errors. The problem is that these frames emit a DOMTitleChanged event that is handled by the tabbrowser element. They pass the |contentWin == contentWin.top| test because that's how <iframe mozbrowser> is supposed to work. But they're not tabs, so we get null when trying to find a tab for the window. This is a simple fix.
Attachment #8360612 - Flags: review?(dao)
Is <iframe mozbrowser> something web content in the wild can and should use? Otherwise, I don't see why the DOMTitleChanged event would bubble up from one of tabbrowser's browsers.

Updated

4 years ago
Blocks: 960492

Updated

4 years ago
Attachment #8360612 - Flags: review?(dao)
Flags: needinfo?(wmccloskey)
I don't see the error anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(wmccloskey)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.