[B2G][Email] Possible to trigger off-screen compose button by clicking at the edge of the card...

RESOLVED FIXED

Status

Firefox OS
Gaia::E-Mail
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Josh Schmitt [Joshs], Assigned: jrburke)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: dogfood1.3)

Attachments

(4 attachments)

(Reporter)

Description

4 years ago
Created attachment 8360678 [details]
Contex_Menu.mpeg

Description:
While composing a new email, top left buttons are selectable behind the context menu.

Repro Steps:
1) Updated Buri to BuildID: 20140113004002
2) Proceed to the Email app
3) Add an Email account
4) Compose a new email
5) Type anything in the body of the Email
6) Tap the back button twice
7) Press cancel button 

Actual:
The button will be selected and open a new composing email.

Expected:
Buttons behind the context menu are not selectable until the context menu is closed.

Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140113004002
Gaia: b3fc4f712562ee92b0ed0bd17abc61be9a36a8da
Gecko: 5bb1837de7c0
Version: 28.0a2
Firmware Version: V1.2-device.cfg
(Reporter)

Comment 1

4 years ago
Created attachment 8360681 [details]
log.txt

Does not reproduce on 1.2, I have attached a logcat.

Environmental Variables:
Device: Buri 1.2 COM
BuildID: 20140102004001
Gaia: b1bc88386c781148a25091bf2eeee3ba217281d0
Gecko: 0c11156c7d9b
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2-device.cfg
Josh - The bug is unclear here. I don't see what the problem here & why this is a bug. Can you clarify?
Flags: needinfo?(jschmitt)
Definitely a bug, but not exactly what I think is being described.

The log excerpt of note is this:
01-15 13:39:16.609: I/GeckoDump(3268): LOG: compose: back: save needed, prompting
01-15 13:39:17.779: I/GeckoDump(3268): LOG: pushCard for type: compose
01-15 13:39:21.479: I/GeckoDump(3268): LOG: compose: canceled compose exit
01-15 13:39:23.919: I/GeckoDump(3268): LOG: compose: back: no save needed, exiting without prompt

The thing is that there is no button on a compose card that can cause a compose card to be pushed.  There is a button in the upper right corner of the message list, and there are buttons on the message reader (of which there are none).

So Josh is managing to click on the compose button that's off the edge of the screen.  Probably because of touch region inflation and the fact that our overlay does not have anything that wants to process the tap in its upper left.

This suggests we need to be making off-screen cards that aren't trays touch-insensitive or file a platform bug about touch inflation being buggy.  Or other things.

:jrburke, thoughts?
Flags: needinfo?(jschmitt) → needinfo?(jrburke)
Summary: [B2G][Email] Buttons behind the context menu are selectable → [B2G][Email] Possible to trigger off-screen compose button by clicking at the edge of the card...
Okay - seems like an edge case (though a bug), so probably won't block on this.
Keywords: regressionwindow-wanted
(Assignee)

Comment 5

4 years ago
Created attachment 8360877 [details] [review]
GitHub pull request

Remove the old hack for bug 828266, because event fluffing makes it possible to click on the "hidden" card areas now, and the hack is no longer needed with more recent gecko versions, no more black sections during card transitions.

Asking :asuth for review since he has history with the old bug. Good-bye lovely hack!
Attachment #8360877 - Flags: review?(bugmail)
Flags: needinfo?(jrburke)
Comment on attachment 8360877 [details] [review]
GitHub pull request

That would explain it!  Totally forgot about the 0.5px!
Attachment #8360877 - Flags: review?(bugmail) → review+
See Also: → bug 950225
(Assignee)

Comment 7

4 years ago
Merged in Gaia master:
https://github.com/mozilla-b2g/gaia/commit/4b6c34b7927daeaef5b3454ac54dcb5593cebedf

from pull request:
https://github.com/mozilla-b2g/gaia/pull/15391
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Comment 8

4 years ago
Created attachment 8361965 [details]
TouchthroughonMovelist.txt

Found another issue that appears to be related to this one, so instead of making a new bug I will post the steps and logcat here. (If a new bug should be filed, I will do so. Apologies for comment spam.)

Repro Steps:
1) Updated Buri to Build ID: 20140113004002.
2) Open E-Mail Application.
3) Go to Inbox in E-Mail App.
4) Select an E-Mail (any email) and attempt to move it to a different folder.
5) On the list that shows the available folders to move to, attempt to scroll up and down.
 
Actual: It's possible to scroll through the Inbox in the background.

Expected: Not able to scroll the inbox in the background.

Environmental Variables
Device: Buri v 1.3.0 Mozilla
Build ID: 20140113004002
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/5bb1837de7c0
Gaia: b3fc4f712562ee92b0ed0bd17abc61be9a36a8da
Platform Version: 28.0a2
Firmware Version: V1.2-device.cfg

Notes:
Repro frequency: 5/5 
 
See attached: logcat (Dev options --> "Enable APZ for all Content.", "Enable Hardware Component", "Remote Debugging", and "Console Enabled."
(Assignee)

Comment 9

4 years ago
That behavior should also be fixed by this changeset.

Updated

4 years ago
Assignee: nobody → jrburke
You need to log in before you can comment on or make changes to this bug.