[DSDS] Even test with the same SIM, what operators Fugu found by manual searching are very different than Buri.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
9 months ago

People

(Reporter: echu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dsdsrun1.3-2, POVB dsdsrun1.4-1)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8360827 [details]
time stamp: 10:45, 1/16

When disable automatic selection in Cellular & Data > Network operator, Fugu will find some strange operators which Buri doesn't have. Please check attached screen shot. Test with CHT SIM.

1. Fugu has CHT and Chungwa two different names which is all refer to the same operator.
2. It has GSM, 46697, forbidden items which Buri doesn't have.
3. It has TCC which is called Taiwan Mobile in Buri.
4. It can't find VIBO which Buri can.

* Build Number  
Fugu              
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2

* Reproduce Steps
1. Insert CHT card. 
2. Go to settings > Cellular & Data > select the SIM, then select Netowork Operator.
3. Disable automatic selection

* Expected Result
Suppose the search result should be similar to Buri, but there are many differences listed above.

* Occurrence rate
100%
(Reporter)

Comment 1

5 years ago
Created attachment 8360828 [details]
screenshots of both buri and fugu
(Reporter)

Updated

5 years ago
Summary: [DSDS] With same CHT SIM, what operators Fugu found by manual searching are very different than Buri. → [DSDS] Even test with the same SIM, what operators Fugu found by manual searching are very different than Buri.

Comment 2

5 years ago
Hi Enpei:
  Please help provide radio log (adb logcat -b main -b radio -v threadtime > /tmp/960374.log) with device log at the same time, I can help check if we got correct information. 
We expect to see "AT+COPS" keyword in log.

Thanks!!
Shawn Ku


01-16 10:47:36.223 I/Gecko   (  106): RIL Worker[1]: Handling parcel as REQUEST_QUERY_AVAILABLE_NETWORKS
01-16 10:47:36.233 I/Gecko   (  106): RIL Worker[1]: Error processing operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): FET
01-16 10:47:36.233 I/Gecko   (  106): RIL Worker[1]: Error processing operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): Chunghwa
01-16 10:47:36.233 I/Gecko   (  106): RIL Worker[1]: Error processing operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): GSM

01-16 10:47:36.243 I/Gecko   (  417): -*- RILContentHelper: fire request success, id: id{713b49f3-8a87-4125-9cbf-665e07bc2a3a}, result: [
{"longName":"Taiwan Cellular Corporation","shortName":"TCC","mcc":"466","mnc":"97","state":"current"},
{"longName":"GSM","shortName":"FarEasTone","mcc":null,"mnc":null,"state":"46601"},
{"longName":"forbidden","shortName":"GSM","mcc":null,"mnc":null,"state":"CHT"},
{"longName":"46692","shortName":"forbidden","mcc":null,"mnc":null}]
Flags: needinfo?(echu)
(Reporter)

Comment 3

5 years ago
Unable to provide the information due to the build I had now has a blocking bug 961577.
Flags: needinfo?(echu)

Updated

5 years ago
See Also: → bug 961577
(Reporter)

Comment 4

5 years ago
(In reply to shawn ku [:sku] from comment #2)
> Hi Enpei:
>   Please help provide radio log (adb logcat -b main -b radio -v threadtime >
> /tmp/960374.log) with device log at the same time, I can help check if we
> got correct information. 
> We expect to see "AT+COPS" keyword in log.
> 
> Thanks!!
> Shawn Ku

Hi Shawn, attach radio log, time stamp: 14:14.
(Reporter)

Comment 5

5 years ago
Created attachment 8362371 [details]
fugu_960374radiolog2.txt

Comment 6

5 years ago
Same as https://bugzilla.mozilla.org/show_bug.cgi?id=961577#c6

*Please also merge the record for the same MCC/MNC. otherwisw, there will be duplicated items on UI.*

{
Chunghwa,CHT,46692,current,UTRAN,
Chunghwa,CHT,46692,available,GSM,
VIBO Telecom Inc,VIBO,46689,available,UTRAN,
Taiwan Cellular Corporation,TCC,46697,forbidden,GSM,
Taiwan Cellular Corporation,TCC,46697,forbidden,UTRAN,
Far EasTone,FET,46601,forbidden,GSM,
Far EasTone,FET,46601,forbidden,UTRAN
}


01-20 14:11:40.870   101   285 D RILC    : [w] [0226]< QUERY_AVAILABLE_NETWORKS  {Chunghwa,CHT,46692,current,UTRAN,Chunghwa,CHT,46692,available,GSM,VIBO Telecom Inc,VIBO,46689,available,UTRAN,Taiwan Cellular Corporation,TCC,46697,forbidden,GSM,Taiwan Cellular Corporation,TCC,46697,forbidden,UTRAN,Far EasTone,FET,46601,forbidden,GSM,Far EasTone,FET,46601,forbidden,UTRAN}

Updated

5 years ago
Flags: needinfo?(sam.hua)

Comment 7

5 years ago
it is because the rilc response.

01-16 10:44:39.783 I/Gecko   (  106): RIL Worker[0]: Error processing operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): CHT
Flags: needinfo?(sam.hua)
(In reply to sam.hua from comment #7)
> it is because the rilc response.
> 
> 01-16 10:44:39.783 I/Gecko   (  106): RIL Worker[0]: Error processing
> operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): CHT

Please see bug 961577 comment #6.
Thank you.
(Reporter)

Comment 9

5 years ago
(In reply to Edgar Chen [:edgar][:echen] from comment #8)
> (In reply to sam.hua from comment #7)
> > it is because the rilc response.
> > 
> > 01-16 10:44:39.783 I/Gecko   (  106): RIL Worker[0]: Error processing
> > operator tuple: Error: Invalid network tuple (should be 5 or 6 digits): CHT
> 
> Please see bug 961577 comment #6.
> Thank you.

Hi Edgar and Shawn, does this bug need help from partner? If so, can we mark this bug as POVB?

Comment 10

5 years ago
Hi Enpei:
 Please mark this issue as POVB.
We need updated ril lib to get this done.

Thanks!!
Shawn

Updated

5 years ago
Component: RIL → Vendcom
(Reporter)

Comment 11

5 years ago
(In reply to shawn ku [:sku] from comment #10)
> Hi Enpei:
>  Please mark this issue as POVB.
> We need updated ril lib to get this done.
> 
> Thanks!!
> Shawn

Thank you so much!
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2, POVB
Whiteboard: dsdsrun1.3-2, POVB → dsdsrun1.3-2, POVB dsdsrun1.4-1
Hi, Shawn, Do we have update on this, thank you.
Flags: needinfo?(sku)

Comment 13

5 years ago
(In reply to Eric Chang [:ericcc] [:echang] from comment #12)
> Hi, Shawn, Do we have update on this, thank you.

Hi Eric:
 Currently, both partner/Mozillian are focusing on 1.3t only (for DSDS).
And this issue need to be fixed by partner RILD.

If fugu need this patch, I can request partner to provide a new ril lib to get rid of the bug.

Thanks!!
Shawn
Flags: needinfo?(sku)

Comment 14

9 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.