Closed Bug 960416 Opened 7 years ago Closed 7 years ago

Always use JIT hardening (i.e. remove javascript.options.jit_hardening pref code)

Categories

(Core :: JavaScript Engine: JIT, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox28 --- wontfix
firefox29 --- fixed

People

(Reporter: cpeterson, Assigned: cpeterson)

References

Details

Attachments

(1 file)

Reading and remembering the jit_hardening pref adds a surprising amount of code to 15 files, but it is only honored by 32-bit Windows builds (running on Windows Vista or later).

Would we ever want to disable jit_hardening? Comments in the original bug suggest disabling the pref will make debugging memory problems easier because VirtualAlloc() will return predictable addresses (because VirtualAlloc() does not support ASLR). However, Windows 8 added ASLR support to VirtualAlloc(), so disabling the jit_hardening pref is only useful for this purported debugging purpose on Windows Vista and 7.
Attachment #8360898 - Flags: review?(luke)
Comment on attachment 8360898 [details] [diff] [review]
jit_hardening.patch

Yeah, I've never toggled that pref in my life.  Actually, I thought the story was that we ignore the pref anyway (deeper down in the guts) because we started getting some hard-to-reproduce WinXP crashes or something...  Either way, no reason for a pref :)
Attachment #8360898 - Flags: review?(luke) → review+
https://hg.mozilla.org/mozilla-central/rev/ea76da4c0f0e
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.