[DSDS] Message settings in Settings does not provide SIM picker for user to choose.

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
7 months ago

People

(Reporter: echu, Unassigned)

Tracking

unspecified
x86_64
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog)

Details

(Whiteboard: dsdsrun1.3-2 dsdsrun1.4-1 dsdsrun1.4-2)

(Reporter)

Description

5 years ago
When open Message settings, there should be a SIM picker like Call settings/Cellular & Data setting have. UX 1.3 v0.8 spec, page 59 has defined it.

* Build Number  
Fugu              
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2

* Reproduce Steps
1. Go to Settings > Message settings.

* Expected Result
There should be a SIM picker for user to choose.

* Actual Result
No SIM picker, it looks like it's only for SIM 1. (If SIM 1 PIN is locked, unable to access this setting)

* Occurrence rate
100%
IIRC Message settings were out of the scope of DSDS for 1.3. Flagging Kevin as he might know.
Flags: needinfo?(khu)

Comment 2

5 years ago
It matches my understanding. Ping Sandip to double confirm.
Flags: needinfo?(khu) → needinfo?(skamat)
(Reporter)

Comment 3

5 years ago
Hi Sandip,

Please also help to confirm whether this should be 1.4+ then if your final decision is not for 1.3. That should also need a user story if it's pushed to 1.4.

Thanks.
Jean

Please check if this bug needs to be moved to 1.4.
Flags: needinfo?(jgong)

Updated

5 years ago
Flags: needinfo?(wmathanaraj)
Flags: needinfo?(skamat)
Flags: needinfo?(jgong)
I think this is already covered in the user stories for v1.4 as we discussed last week in Paris. 

Enpei: can you confirm if your request is met in the UX specs we have for v1.4 DSDS
Flags: needinfo?(wmathanaraj) → needinfo?(echu)
(Reporter)

Comment 6

5 years ago
(In reply to Wilfred Mathanaraj [:WDM] from comment #5)
> I think this is already covered in the user stories for v1.4 as we discussed
> last week in Paris. 
> 
> Enpei: can you confirm if your request is met in the UX specs we have for
> v1.4 DSDS

Hi Wilfred, both 1.3 and 1.4 UX spec include it. So we may need your judgment deciding whether 1.3 should still implement it or not.
Flags: needinfo?(echu)
move it to v1.4 for implementation.
Changing flag to 1.4? per #Comment 7
blocking-b2g: 1.3? → 1.4?

Comment 9

5 years ago
Wesley,

Would you help to triage this and see if it is needed in v1.4?
Flags: needinfo?(whuang)

Comment 10

5 years ago
We don't have plan to do it in 1.4.
blocking-b2g: 1.4? → ---
(Reporter)

Comment 11

5 years ago
As my comment 6, if this is still not implemented in 1.4, please give us a clear target milestone since both 1.3 and 1.4 UX spec includes it, it's very weird to have only call and cellular&Data settings have the sim picker while Message doesn't.

Hi Joe, can you help on this?
Flags: needinfo?(jcheng)
If this is a feature and not included in the set of "Bug 945641", then we won't have it in 1.4.
I'll leave the call to Joe for determining whether and when to implement.
Flags: needinfo?(whuang)
Enpei, can you attach the UX spec you are looking at, i cannot find the UX spec you are referring to (none of the specs i look at now has page 59)

and whats the current behavior, if the Message settings shows the settings of the user-preferred SIM for sending message, then i think we can live with it. Can you help us understand more? Thanks
Flags: needinfo?(jcheng) → needinfo?(echu)
i think i know what you are referring to. I'd like to ni? Arthur for background on this. i'd expect this is implemented
Flags: needinfo?(arthur.chen)
(Reporter)

Comment 15

5 years ago
(In reply to Joe Cheng [:jcheng] from comment #13)
> Enpei, can you attach the UX spec you are looking at, i cannot find the UX
> spec you are referring to (none of the specs i look at now has page 59)
> 
> and whats the current behavior, if the Message settings shows the settings
> of the user-preferred SIM for sending message, then i think we can live with
> it. Can you help us understand more? Thanks

Hi Joe, [1.4 DSDS] General guideline v0.2.pdf page 36.
Flags: needinfo?(echu)
The panel of message settings were part of the call settings panel. It was moved to the first level in 1.3 so it does not have sim selector. As most of the message settings apply to the device instead of individual sim cards, it might not appropriate to use the sim selector in the beginning.

Steve, could you share which message settings should be separated for individual sim cards?
Flags: needinfo?(arthur.chen) → needinfo?(schung)
The information I got from gecko side is they didn't notice any UX requirement about this SIM picker ability for message settings. Since making these settings value to global doesn't affect usability(and referenced Android phone didn't separate message settings either), having a separated message related settings value for both SIM does not in their 1.3 nor 1.4 plan.

Hi Joe, if you feel this item is neccesary for DSDS device, we could only put it after 1.4 because this task require lots of changes in both gecko and gaia, and we didn't start it yet.
Flags: needinfo?(schung) → needinfo?(jcheng)
Thanks Steve. I am fine with having one menu in such case
ni Carrie/Wilfred to confirm on the UX/Product side. Thanks
Flags: needinfo?(jcheng) → needinfo?(cawang)
Flags: needinfo?(wmathanaraj)
Not happy with it. :(
It will look really inconsistent with other items in Settings. Since we let users select a primary SIM for messages, they might have the concept (from Call settings) that they can do the settings separately on both SIM. However, if we really don't have time, then, I can live with it (for now).
Flags: needinfo?(cawang)
Whiteboard: dsdsrun1.3-2 → dsdsrun1.3-2 dsdsrun1.4-1
blocking-b2g: --- → 1.4?
blocking-b2g: 1.4? → backlog
Commenting on Wilfred's behalf while he is out:
I think the backlog decision is the right one here.  Let's fix this, but we shouldn't hold up the whole release on this.
Flags: needinfo?(wmathanaraj)
Whiteboard: dsdsrun1.3-2 dsdsrun1.4-1 → dsdsrun1.3-2 dsdsrun1.4-1 dsdsrun1.4-2
(Assignee)

Updated

4 years ago
blocking-b2g: backlog → ---
tracking-b2g: --- → backlog

Comment 21

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.