[Buri][Data usage] Show a specific message when launching data usage app under airplane mode scenario

RESOLVED FIXED in 1.4 S4 (28mar)

Status

Firefox OS
Gaia::Cost Control
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: noemi, Assigned: mai)

Tracking

unspecified
1.4 S4 (28mar)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Created attachment 8360992 [details]
2014-01-16-v1.3-Bug908599.png

Checked on v1.3 01/16 build:
Device: Hamachi
Gecko: 0f53789
Gaia: 423326d
Platform: 28.0a2
BuildId: 20140116065120

STR:
1- Turn on the airplane mode
2- Launch data usage app the first time (or subsequents). Please, see the attached file, it is the current message shown

It would be nice to have a more concrete message under this scenario such as other applications do. Something similar to:
Airplane mode activated
Turn off airplane mode to access to data usage information
ni to UX to confirm
(Reporter)

Updated

4 years ago
Flags: needinfo?(hhsu)

Comment 1

4 years ago
Yes, it would be nice to have a concrete message like "Please turn off airplane mode to enable Usage".
To differentiate between No Sim card and Airplane mode, and avoid user confusion
Flags: needinfo?(hhsu)

Comment 2

4 years ago
It's possible to detect airplane mode by shared/js/airplane_mode_helper
(Assignee)

Updated

4 years ago
Assignee: nobody → mri
(Assignee)

Comment 3

4 years ago
Created attachment 8364297 [details] [review]
patch v1.0

Please, could you review the code?
Attachment #8364297 - Flags: review?(salva)
(Assignee)

Updated

4 years ago
Depends on: 963682
(Assignee)

Comment 4

4 years ago
Hi Alive,
Could you confirm if the following behavior of system is correct?
STR.
    1. The user starts the costcontrol application with the airplaneMode enabled.
    2. The user disables the airplaneMode
    3. System does not show the "pin required screen", when icc is detected on costcontrol application.

Thanks!
Flags: needinfo?(alive)
Comment on attachment 8364297 [details] [review]
patch v1.0

With the current patch version, as the widget is not listening for changes in airplane mode, two issues arise:

1- The widget is not showing the airplane message but the one for no SIM.

STR:

 0. With an already configured SIM.
 1. Pull down utility tray.
 2. Enable airplane mode.
 3. Observe the widget UI does not change. *
 4. Hide the utility tray.
 5. Pull down utility tray.

Expected:
Airplane mode message is shown.

Actual:
No SIM message is shown.

2- The widget is not showing the proper view when airplane mode is disabled.

STR:

 0. Repeat steps from 0 - 5 from the issue 1.
 1. Switch off the Airplane mode.

Expected:
The widget shows the proper view. *

Actual:
The widget remains in the error message.

* Until now, the widget can not be visible while switching the state: you can not transition to NO-SIM without rebooting the device or you can not lock the SIM without hiding the widget but now you can transition to "airplane mode" and keep viewing the widget so we should file a bug for this case.

Let's focus on issue 1 in this bug and open a follow up with the issue 2 for the number 2.
 
In addition, see my comments on GitHub and rebase the patch, please.
Thank you!
Attachment #8364297 - Flags: review?(salva) → review-
(Assignee)

Comment 6

4 years ago
Comment on attachment 8364297 [details] [review]
patch v1.0

Updated the PR with your comments
Attachment #8364297 - Flags: review- → review?(salva)
Flags: needinfo?(alive)
(Assignee)

Updated

4 years ago
Duplicate of this bug: 970323
(Reporter)

Comment 8

4 years ago
Per comment7, Bug 970323 was nominated to v1.3? so then nominating this bug too.
blocking-b2g: --- → 1.3?

Updated

4 years ago
Keywords: regression
(In reply to Noemí Freire (:noemi) from comment #8)
> Per comment7, Bug 970323 was nominated to v1.3? so then nominating this bug
> too.

This is not a dupe. This bug deals with messaging with airplane mode is active, where as the other bug deals with the case when airplane mode is disabled & the widget is not working.
blocking-b2g: 1.3? → ---
Keywords: regression
Comment on attachment 8364297 [details] [review]
patch v1.0

See my comments on GitHub and ask for my review once all is fixed. Thank you.
Attachment #8364297 - Flags: review?(salva)
(Assignee)

Comment 11

4 years ago
Comment on attachment 8364297 [details] [review]
patch v1.0

Updated the PR with your comments.
Regards
Attachment #8364297 - Flags: review?(salva)
Comment on attachment 8364297 [details] [review]
patch v1.0

I have a doubt about this patch, can you address the problem reported on GitHub or answer me and ask for my review again? In general, it looks good.
Attachment #8364297 - Flags: review?(salva)
(Assignee)

Comment 13

4 years ago
Comment on attachment 8364297 [details] [review]
patch v1.0

Updated the PR with your comments.
Regards
Attachment #8364297 - Flags: review?(salva)
Comment on attachment 8364297 [details] [review]
patch v1.0

Code is Ok but try this STR to see an unexpected behaviour:

1. Pull down the utility tray.
2. Enable airplane mode, the widget will change to the airplane message.
3. Hide the utility tray.
4. Show the utility tray again.

Expected:
The widget shows the same message as in the step 2.

Actual:
The widget shows "No SIM inserted" message.
Attachment #8364297 - Flags: review?(salva) → review-
(Assignee)

Comment 15

4 years ago
Comment on attachment 8364297 [details] [review]
patch v1.0

Nice catch, thanks!
I forget check the airplane mode when the event onVisibilityChange is fired.

Updated the PR to cover this STR.
(Assignee)

Updated

4 years ago
Attachment #8364297 - Flags: review- → review?(salva)
Comment on attachment 8364297 [details] [review]
patch v1.0

All working well now. Thank you Mai.
Attachment #8364297 - Flags: review?(salva) → review+
(Assignee)

Comment 17

4 years ago
Master:66da954e077f9ef35ad0cded43aa32a7dace9020
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Reporter)

Updated

4 years ago
Target Milestone: --- → 1.4 S4 (28mar)

Updated

4 years ago
Depends on: 987283
This hasn't been uplifted to 1.4 and we are past string freeze, so should the target milestone be updated to '1.5 S! (9may)'?
(Reporter)

Comment 19

4 years ago
(In reply to Archaeopteryx [:aryx] from comment #18)
> This hasn't been uplifted to 1.4 and we are past string freeze, so should
> the target milestone be updated to '1.5 S! (9may)'?

Hi,

The target milestone was set based on when the patch was fixed (before Mar 28), please feel free to set a new target milestone for string purposes if needed.
(Assignee)

Updated

4 years ago
Blocks: 991831
You need to log in before you can comment on or make changes to this bug.