Implement calls in proper tail position as proper tail calls in SpiderMonkey

RESOLVED DUPLICATE of bug 723959

Status

()

defect
RESOLVED DUPLICATE of bug 723959
6 years ago
5 years ago

People

(Reporter: marc.nieper, Unassigned)

Tracking

(Blocks 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131206145143




Expected results:

The proposed 6th Edition of the ECMAScript Language Specification (Draft November 8, 2013) requires that ECMAScript engines implement calls in proper tail position as proper tail calls.

SpiderMonkey will have to follow this requirement to become an omplementation of ECMAScript 6.

Implementing proper tail call semantics does not change backward compatibility with any previous edition of ECMAScript or JavaScript so could already be started independently. With it, the language could be used in a truely functional style, or in a CPS, or as a good compilation target for languages with PTC semantics.
Reporter

Updated

6 years ago
Blocks: es6
Note bug 565374, which this may well be a duplicate of.
For that matter, note bug 723959.
Status: UNCONFIRMED → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 723959
You need to log in before you can comment on or make changes to this bug.