POP login handling of incorrect passwords

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
7 months ago

People

(Reporter: worldoff9908, Unassigned)

Tracking

SeaMonkey 2.23 Branch
x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23 (Beta/Release)
Build ID: 20131210201652

Steps to reproduce:

I don't allow the Seamonkey password manager to remember my POP passwords.  So that I don't forget them, I allow for prompting at the beginning of each session.

On one server, if I make a typo in the password, authentication fails, and I get a new prompt for the password.  


Actual results:

When I re-enter the password correctly, the connection is rejected.

Work-around: after second failed connection (with correct password), click "cancel", then click "Get Messages", and authentication happens correctly.


Expected results:

Transmission of corrected password on the first try.

I'm finding that this happens on some mail servers, but not others.  I'm seeing this effect at fastmail.fm, but not on a corporate mail server.

I've been noticing this problem since Seamonkey 2.22, although I notice discussion in mozilla.support.thunderbird forum, back in October, indicating similar problems with Thunderbird.

Comment 1

7 months ago
I never observed such a problem with unzipped installer of  official en-US SeaMonkey 2.53a1 (NT 6.1; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0 Build 20170706013410  (Default Classic Theme) on German WIN7 64bit or earlier SeaMonkey versions.

So WFM for now.

@Reporter: Please feel free to reopen this Bug if you still can reproduce the problem with a current SeaMonkey version and if you can contribute a step by step instruction how other users can reproduce the problem reliably due to <https://developer.mozilla.org/en-US/docs/Mozilla/QA/Bug_writing_guidelines>  (containing every key press and every mouse click).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.