Form post with action set to query only URL posts to incorrect URI

VERIFIED DUPLICATE of bug 90439

Status

()

Core
Layout
VERIFIED DUPLICATE of bug 90439
17 years ago
17 years ago

People

(Reporter: rossb, Assigned: clayton)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
If i have a form with an action that looks like "?queryargs=queryvalues" the 
form is not posted to the current URI, but to /

To repro:
1) go to,
http://nsrepro.westside.com/formpostRepro.ws?_fn=repro
2) the form is set to post to 
action="?_fn=doPost"
3) select Submit Query button

Results:
Post to
http://nsrepro.westside.com/?_fn=doPost
(error no default page found)

Expected:
Post to
http://nsrepro.westside.com/formpostRepro.ws?_fn=doPost
(prints post successful message)

:)ross

*** This bug has been marked as a duplicate of 90439 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

Updated

17 years ago
QA Contact: bsharma → moied

Comment 3

17 years ago
Verified dup of 90439 which is fixed,  Verified URL with build ID 20020131 on
win2k its fixed.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.