Closed Bug 960720 Opened 6 years ago Closed 6 years ago

Change the client side Smart Collection wallpapers

Categories

(Firefox OS Graveyard :: Gaia::Everything.me, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1016221

People

(Reporter: padamczyk, Assigned: amirn)

References

Details

(Whiteboard: ux-tracking, visual design, visual-tracking, bokken )

Attachments

(2 files, 4 obsolete files)

Change the wallpapers of the smart collections that ship on the device so they fit better with the direction of the OS.
No longer depends on: 951289
Flags: needinfo?(pla)
Blocks: 965711
Assignee: nobody → amirn
Status: NEW → ASSIGNED
We need new icons for every predefined Collection.
Who can provide the new assets?


As a reference, the current icons for 'Social' are here:
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/collections/social

List of predefined collections:
https://github.com/mozilla-b2g/gaia/tree/master/apps/homescreen/collections/
Flags: needinfo?(padamczyk)
Question - 
What should happen when renaming a pre-installed (shipped on device) collection?
Should the bg change to reflect the new name or not?
We should also update the customization instructions on https://wiki.mozilla.org/B2G/MarketCustomizations#homescreens.json when this lands.
Flags: needinfo?(padamczyk)
No longer blocks: 965711
Depends on: 965711
Here are the smart collection graphics, we export them at 320x480 first, just want to make sure they work correctly first: https://mozilla.box.com/s/x97kfv029ivmwgklt724
Flags: needinfo?(pla)
Attached image screenshot-homescreen.png (obsolete) —
Attached image screenshot-social.png (obsolete) —
Thanks Patryk, added screenshots with the new graphics.
Regarding the different sizes for the assets, we discussed having different version per device height:
320x480.png, 480x800.png, 480x854.png, 540x960.png, 720x1280.png and 1080x1920.png

I am not sure the device height is available in build time (ni? yurenju)

in case it is not available, maybe a better solution will be to use the @2x, @2.5 versioning?
Flags: needinfo?(yurenju.mozilla)
Attached image 10-collections.png (obsolete) —
updated PR to include all 10 default collections on homescreen (attached screenshot).

please note that if you |reset-gaia| with this branch, the new icons will appear only after a collection updates, meaning - one of the first 3 apps have changed.

for the Social collection you will have to reorder the first 3 apps to trigger an update. for the rest of the collections it will be enough to open it (make sure device is online so web apps can load and trigger the update).
Notice, the apps that appear in the Collection icons, in the screenshot attached, are local (Israel related).
When YOU update your device, it'll show apps that are relevant to YOUR location.
Amir, I thought I replied this bug but seems not, sorry.

the resolution information is not available on build time, so yes, using filename like @2x.jpg will be better than using resolution.
Flags: needinfo?(yurenju.mozilla)
Blocks: 1016221
Blocks: 1016224
Attached file PR (obsolete) —
Attachment #8403168 - Attachment is obsolete: true
Attachment #8403169 - Attachment is obsolete: true
Attachment #8404640 - Attachment is obsolete: true
Attachment #8432220 - Flags: review?(ran)
Attached file PR
Attachment #8432220 - Attachment is obsolete: true
Attachment #8432220 - Flags: review?(ran)
Attachment #8432227 - Flags: review?(ran)
Attachment #8432227 - Flags: review?(ran) → review+
landed: https://github.com/mozilla-b2g/gaia/commit/c3fe464
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Backed out:

commit: 2680cf4fc70c59cf801aab8283c0b3178175e3cf
Revert "Bug 960720 - Change the client side Smart Collection wallpapers [r=ranbena]"
This reverts commit 13c94ca.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
patch to big and blocks hamachi builds - bug 1019321
not sure how to handle this
Depends on: 1019321
(In reply to Amir Nissim (Everything.me) from comment #19)
> patch to big and blocks hamachi builds - bug 1019321
> not sure how to handle this

Let me ask UX.

UX - The file changes being requested here are too big in size. Can you figure out a mitigation plan here?
Flags: needinfo?(firefoxos-ux-bugzilla)
Clearing the ni? for UX since this is being dealt with at a broader scale.
Flags: needinfo?(firefoxos-ux-bugzilla)
When you decide if this is migrated to @1.5, etc.. please let me know for bug 1020134, thanks
Depends on: 1020134
QA Whiteboard: [VH-FL-blocking-][VH-FC-blocking-]
In bug 1030440 Jacqueline has defined the three collections that should ship with the device as Social, Games, and Music. Because the full set is too large, one option might be to build with only these three, and have the rest come from the server. The problem with this is that I'm not sure if the suggestions list would be able to determine the difference between the defaults which we store locally, and results from the server. We don't want to remove a default collection, then re-add it to see a different icon for example. Potentially serving all background assets from a CDN might be the best option here. 

Also we should definitely use .png, @1.5x, @2x, etc extensions because that's how we ship the proper image to the device - it would probably help here.
No longer blocks: 1016221
No longer blocks: 1016224
Implemented for vertical homescreen
Status: REOPENED → RESOLVED
Closed: 6 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1016221
You need to log in before you can comment on or make changes to this bug.