Applying filter on SVG element causes that element is not visible when SVG is included without <html></html> already present

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
6 years ago
4 years ago

People

(Reporter: eryk.piast, Unassigned)

Tracking

28 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/32.0.1700.77 Safari/537.36

Steps to reproduce:

1. Create empty iframe (default without DOCTYPE)
2. Create SVG document and attach it to iframe body
3. Create image element and attach it to SVG
4. Create filter, attach it to SVG and apply on image
5. See, that you can't see image :)

http://jsfiddle.net/erykpiast/3Z7gY/2/


Actual results:

Element with filter is not visible


Expected results:

Element with filter is visible
Whiteboard: svg, doctype, filter, iframe
Whiteboard: svg, doctype, filter, iframe → [triage] [defect] p=0
Posted image Screenshot.png
Please see the attached screenshot: this is how it looks for me with latest Aurora on Ubuntu 13.10 32-bit. Is this the issue you are seeing?
Flags: needinfo?(eryk.piast)
Component: Untriaged → SVG
Product: Firefox → Core
(In reply to Manuela Muntean [:Manuela] [QA] from comment #1)
> Created attachment 8369335 [details]
> Screenshot.png
> 
> Please see the attached screenshot: this is how it looks for me with latest
> Aurora on Ubuntu 13.10 32-bit. Is this the issue you are seeing?

Yep, it looks like on your screenshot.
Flags: needinfo?(eryk.piast)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: fxdesktoptriage
No longer blocks: fxdesktopbacklog
Whiteboard: [triage] [defect] p=0 → [triage] p=0
The DOCTYPE is not important, the <html></html> is i.e. if you make the commented out line in the testcase

$iframe.contents()[0].write('<html></html>'); 

it works.
Summary: Applying filter on SVG element causes that element is not visible when SVG is included in HTML document without DOCTYPE → Applying filter on SVG element causes that element is not visible when SVG is included without <html></html> already present
Ave Robert,

I was experimenting a bit and I proved, that you can write anything to iframe (by document.write) and filtered SVG element shows up. I blamed DOCTYPE too soon :)

http://jsfiddle.net/3Z7gY/4/
Blocks: fxdesktopbacklog
No longer blocks: fxdesktoptriage
Whiteboard: [triage] p=0 → p=0
No longer blocks: fxdesktopbacklog
Whiteboard: p=0
Seems to work now.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
(In reply to Robert Longson from comment #5)
> Seems to work now.

What version?
You need to log in before you can comment on or make changes to this bug.