B2G: Failed to run xpcshells: mozdevice.devicemanager.DMError: gaia/build/busybox-armv6l

RESOLVED DUPLICATE of bug 932362

Status

Firefox OS
General
RESOLVED DUPLICATE of bug 932362
5 years ago
4 years ago

People

(Reporter: allstars, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

When running xpcshell tests for B2G, it will throw an error
mozdevice.devicemanager.DMError: ... gaia/build/busybox-armv6l

See also 
https://bugzilla.mozilla.org/show_bug.cgi?id=953161#c6
Depends on: 953161
Summary: mozdevice.devicemanager.DMError: gaia/build/busybox-armv6l → B2G: Failed to run xpcshells: mozdevice.devicemanager.DMError: gaia/build/busybox-armv6l
See https://bugzilla.mozilla.org/show_bug.cgi?id=874379#c15 .  Best solution might be building busybox from source on all supporting platforms, or we'll have to find some where to host those binaries again.
A temporary solution:

  gaia$ git checkout 5aef183406fdef74c6cdacb36a7f9a6764caddd0^ -- build/busybox-armv6l

Or you can download it from https://github.com/mozilla-b2g/gaia/raw/ec1064218fef0fadcead7a64a9ae423b655c71d0/build/busybox-armv6l inside your gaia/ folder.
Use `./mach xpcshell-test` instead.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 932362
You need to log in before you can comment on or make changes to this bug.