If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Disable pref extensions.getAddons.cache.enabled for Firefox and MetroFirefox to not interfere with AMO statistics

RESOLVED FIXED

Status

Testing
Mozbase
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Andrei Eftimie, Assigned: Andrei Eftimie)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

4 years ago
We need to set `extensions.getAddons.cache.enabled` to `false` to the Firefox and MetroFirefox profile.

Without this preference installing a local addon while connected to a router that isn't connected to the internet will fail.

Some addition info here: https://blog.mozilla.org/addons/how-to-opt-out-of-add-on-metadata-updates/
The above mentioned issue is not the fundamental one. It's more that for add-ons you install a connection to AMO is made and information is transferred. This should not be allowed for test harnesses.

I would like to see this included for Mozmill 2.0.4.
Blocks: 960495
(Assignee)

Comment 2

4 years ago
Created attachment 8361610 [details] [diff] [review]
0001-Bug-960976-Set-extensions.getAddons.cache.enabled-to.patch

Added the required pref to the profiles.
Assignee: nobody → andrei.eftimie
Status: NEW → ASSIGNED
Attachment #8361610 - Flags: review?(hskupin)
Summary: Add pref extensions.getAddons.cache.enabled = false to Firefox and MetroFirefox profile to be able to install local addons without a working Internet Connection → Disable pref extensions.getAddons.cache.enabled for Firefox and MetroFirefox to not interfere with AMO statistics
No longer blocks: 958126
Comment on attachment 8361610 [details] [diff] [review]
0001-Bug-960976-Set-extensions.getAddons.cache.enabled-to.patch

Review of attachment 8361610 [details] [diff] [review]:
-----------------------------------------------------------------

r=me with the mentioned nit fixed.

::: mozprofile/mozprofile/profile.py
@@ +331,5 @@
>                     'extensions.autoDisableScopes' : 10,
>                     # Don't install distribution add-ons from the app folder
>                     'extensions.installDistroAddons' : False,
> +                   # Don't send the list of installed addons to AMO
> +                   'extensions.getAddons.cache.enabled' : False,

nit: please keep the alphabetical order.
Attachment #8361610 - Flags: review?(hskupin) → review+
(Assignee)

Comment 4

4 years ago
Created attachment 8362392 [details] [diff] [review]
0001-Bug-960976-Set-extensions.getAddons.cache.enabled-to.patch

*sigh* it seems I no longer know the alphabet :|

Thanks for catching that!
Attachment #8361610 - Attachment is obsolete: true
Attachment #8362392 - Flags: review?(hskupin)
Attachment #8362392 - Flags: review?(hskupin) → review+
Landed on master:
https://github.com/mozilla/mozbase/commit/1cdf05a7cf43b5dc67e52d1038c998147f15abee
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 958126
You need to log in before you can comment on or make changes to this bug.