Closed Bug 961 Opened 22 years ago Closed 21 years ago

[BLOCKER] Document dimensions not exposed to JS yet

Categories

(Core :: DOM: Core & HTML, defect, P1)

x86
Windows 95
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: angus, Assigned: vidur)

References

Details

(Whiteboard: [TESTCASE] document.width not implemented yet)

Attachments

(1 file)

document.width
window.innerWidth
window.outerWidth

... not implemented yet. I need to get this value for some XPFE stuff I'm
working on. I do not need set yet.
Status: NEW → ASSIGNED
window.innerWidth should work now.

window.outerWidth waiting on api's into widget stuff.

we'll need to decide what to do with document.width
Setting all current Open/Normal to M4.
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser
QA Contact: 4015 → 4616
QA contact re-assigned according to the product areas we're currently working
on.
Component: Event Handling → DOM Level 0
Component updated to DOM Level 0.
Target Milestone: M4 → M5
Not critical for M4 at this point, moving to M5
Target Milestone: M5 → M6
Moving out to M7
Target Milestone: M7 → M8
Summary: Document/Window dimensions not exposed to JS yet → Document dimensions not exposed to JS yet
Target Milestone: M8 → M11
I believe the window parts of this now work.  Just the document dimensions
don't.  Those are less important and less well defined.  Chaning summary and
pushing farther down.
Whiteboard: [MAKINGTEST] christian@wenz.org
Whiteboard: [MAKINGTEST] christian@wenz.org → [TESTCASE] document.width not implemented yet
Overview Description: document.width is not implemented yet

Steps to reproduce: load the attachment. Note that window.innerWidth,
window.outerWidth and document.width are read.

Actual Results: You get values for window.innerWidth and window.outerWidth, and
document.width = undefined

Expected Results: document.width = [any number]

Build Date & Platform: M7 and 1999070917 build (Win32)

Additional information: the innerWidth/outerWidth implementation seems to be
buggy, I'll file an extra bug report for that.
jfyi: the window.[inner|outer]Width bug is #9606. I did  not send a dependency
to this bug, as bug #961 is now limited to document.width
Blocks: 7998
I need document.height too.
Summary: Document dimensions not exposed to JS yet → [BLOCKER] Document dimensions not exposed to JS yet
Upgrading to blocker.
Blocks: 12659
Blocks: 13465
No longer blocks: 12659
Assignee: joki → brendan
Status: ASSIGNED → NEW
Joki said I could have this one; could use advice from troy or kipp for source
of document height and width in pixels.

/be
I see that the document height and width is computed in nsScrollFrame::Reflow()
and nsGfxScrollFrame::Reflow(). The values are not saved into any member
variables. I am not sure how you would get these values to
nsHTMLDocument::GetWidth() and nsHTMLDocument::GetHeight().
Assignee: brendan → vidur
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Fix checked in on 10/6/1999. Reviewed by Troy.
Status: RESOLVED → VERIFIED
Tested with 10-09-09. Working fine. Marking verified.
No longer blocks: 13465
You need to log in before you can comment on or make changes to this bug.