Closed Bug 961231 Opened 6 years ago Closed 6 years ago

[B2G][SMS]To: Text field’s subtext region is truncated

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(b2g-v1.2 unaffected, b2g-v1.3 fixed, b2g-v1.4 fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.2 --- unaffected
b2g-v1.3 --- fixed
b2g-v1.4 --- fixed

People

(Reporter: pbylenga, Assigned: steveck)

References

Details

(Keywords: regression, Whiteboard: burirun1.3-2)

Attachments

(2 files)

Description:
The subtext (bottom) region of the To: field in the SMS app is truncated. This issue does not reproduce in the body text area or the Subject area of a MMS.

Repro Steps:
1) Updated Buri to Build ID: 20140117004005
2) Launch Message App
3) Tap pencil in top right hand corner to compose a new message
4) In To Field type characters that descend into subtext region “g” and observe

Actual:
Text is truncated

Expected:
Text is able to be observed in its entirety

Environmental Variables
Device: Buri v1.3 Mozilla RIL
Build ID: 20140117004005
Gecko: http://hg.mozilla.org/releases/mozilla-aurora/rev/2c033140eff4
Gaia: a81ccdc53e45a6adeaae423e104e91bcc1e12b0e
Platform Version: 28.0a2
Firmware Version: v1.2-device.cfg

Notes:
Repro frequency: 5/5, 100%
See attached: screenshot
This issue does not reproduce on v1.2

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20140114004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/42a1c35fc831
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Platform Version: 26.0
RIL Version: 01.01.00.019.281 
Firmware Version: v1.2-device.cfg
.:First Broken Build:.
Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140114004002
Gaia: 96c05def12ed7a9896b23f45398e361a97d2ce0e
Gecko: 29c5b8def408
Version: 28.0a2
Firmware Version: v1.2-device.cfg

.:Last Working Build:.
Environmental Variables:
Device: Buri 1.3 MOZ
BuildID: 20140113004002
Gaia: b3fc4f712562ee92b0ed0bd17abc61be9a36a8da
Gecko: 5bb1837de7c0
Version: 28.0a2
Firmware Version: v1.2-device.cfg
QA Contact: gbennett
Minor VD regression.
I think this comes from bug 946744: in this patch, I switch from "box-sizing: content" to "box-sizing: border-box".
Blocks: 946744
I'm requesting 1.3? for a regression, even minor.

Steve, can you have a look at this?

You'll need to check the style for recipients in the following states:
* "assimilated" (it means, valid recipient enclosed in the box)
* being edited
* invalid

And test both long (triggering an ellipsis) and short.
blocking-b2g: --- → 1.3?
Flags: needinfo?(schung)
I can take a look.
Assignee: nobody → schung
Flags: needinfo?(schung)
Attached file Link to github
Since recipient's box modual changes to border-box, we have to add the border width back to the height(or decrease the line-height).
Attachment #8362453 - Flags: review?(felash)
Comment on attachment 8362453 [details] [review]
Link to github

r=me

thanks for the quick fix !! I knew you were the good one here ;)
Attachment #8362453 - Flags: review?(felash) → review+
Comment on attachment 8362453 [details] [review]
Link to github

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): bug 946744
[User impact] if declined: visual glitch (see attachment 8361910 [details])
[Testing completed]: yes
[Risk to taking this patch] (and alternatives if risky): very low
[String changes made]: none
Attachment #8362453 - Flags: approval-gaia-v1.3?(fabrice)
Landed in master: 8153f963205701dba9fceb52982a0aba67544bad
I will set uplift flag if issue becomes 1.3 blocking or get v1.3 approval.
Sorry the flag already set... let's wait for triage or approval process.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
It's not blocking, it just needs approval.  Preeti, please approve?
blocking-b2g: 1.3? → ---
Flags: needinfo?(praghunath)
Attachment #8362453 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Comment on attachment 8362453 [details] [review]
Link to github

done
Flags: needinfo?(praghunath)
Landed in v1.3 : 744fb691c2b2a25a07c5d19fabf5748ae9aba4d9
blocking-b2g: --- → 1.3?
blocking-b2g: 1.3? → ---
You need to log in before you can comment on or make changes to this bug.