./mach mochitest-remote fails on an ics b2g emulator build

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Ehsan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
$ ./mach mochitest-remote

/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/python/mach/mach/main.py:238: UserWarning: Module mozprocess was already imported from /media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/mozbase/mozprocess/mozprocess/__init__.pyc, but /usr/local/lib/python2.7/dist-packages/mozprocess-0.13-py2.7.egg is being added to sys.path
  import pkg_resources
/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/python/mach/mach/main.py:238: UserWarning: Module mozfile was already imported from /media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/mozbase/mozfile/mozfile/__init__.pyc, but /usr/local/lib/python2.7/dist-packages/mozfile-0.12-py2.7.egg is being added to sys.path
  import pkg_resources
From _tests: Kept 10992 existing; Added/updated 0; Removed 0 files and 0 directories.
Error running mach:

    ['mochitest-remote']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.

You should consider filing a bug for this issue.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ImportError: No module named py.xml

  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/mochitest/mach_commands.py", line 640, in run_mochitest_remote
    xre_path=self.xre_path, test_file=test_file, **kwargs)
  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/mochitest/mach_commands.py", line 128, in run_b2g_test
    ('.py', 'r', imp.PY_SOURCE))
  File "/home/ehsan/moz/b2g-ics-emu/objdir-gecko/_tests/testing/mochitest/runtestsb2g.py", line 24, in <module>
    from marionette import Marionette
  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/marionette/client/marionette/__init__.py", line 11, in <module>
    from runner import *
  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/marionette/client/marionette/runner/__init__.py", line 6, in <module>
    from mixins import *
  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/marionette/client/marionette/runner/mixins/__init__.py", line 6, in <module>
    from reporting import *
  File "/media/storage/moz/b2g-ics-emu/../../../../home/ehsan/moz/src/testing/marionette/client/marionette/runner/mixins/reporting.py", line 13, in <module>
    from py.xml import html
ehsan@teenux:~/moz/b2g-ics-emu$
(Reporter)

Updated

5 years ago
Blocks: 924972
This looks like bug 950098 which was fixed Dec. 18th. You're either using an older checkout that doesn't have the fix, or you are in python package hell :). Judging by the warnings at the top I'd guess the latter.

Try nuking 'marionette' from /usr/local/lib/python2.7/dist-packages. It's probably also safe to remove all other moz* packages while you're at it. If that doesn't work, or if you are using an older checkout, there's a workaround here: https://bugzilla.mozilla.org/show_bug.cgi?id=950098#c9
(Reporter)

Comment 2

5 years ago
This was indeed caused by an old checkout.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.