If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[B2G][Media Recorder]Pausing/resuming an audio stream does not record properly.

RESOLVED WORKSFORME

Status

()

Core
Audio/Video: Recording
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Ross Kuhlman (rkuhlman@qanalydocs.com), Assigned: rlin)

Tracking

unspecified
ARM
Gonk (Firefox OS)
Points:
---

Firefox Tracking Flags

(b2g-v1.2 unaffected, b2g-v1.3 affected)

Details

(Whiteboard: burirun1.3-2)

Attachments

(1 attachment)

Created attachment 8361950 [details]
AudioRecorderLog.txt

Record a stream derived from opus file with no timeslice that is paused and resumed for 1/2 the length of time of opus playback, verify blob generated produces sound for non-paused timeframe.

Repro Steps:
1) Updated Buri to BuildID: 20140115004003
2) Go to http://mozilla.github.io/qa-testcase-data/webapi/mediarecorder/index.html and select setup under setup opus stream for media recorder
3) Select play on the input & output media controls.
4) Select start recording.
5) After three seconds, select pause on both media controls.
6) After six seconds select resume play on both media controls.
7) After three seconds, select stop recording.
8) Select the blob URL

Actual:
User hears playback of the first 3 seconds of recording.

Expected:
User hears playback of the entire 6 seconds of recording.

Environmental Variables:
Device: Buri v1.3 Moz RIL
BuildID: 20140115004003
Gaia: 14e199d6a9ad917eacad883820a9f7619dbf42c8
Gecko: d7260b206e91
Version: 28.0a2
Firmware Version: v1.2-device.cfg

Notes:

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/10002/
See attached: logcat
Issue does not occur in v1.2
Environmental Variables:
Device: Buri v1.2 Moz RIL
BuildID: 20140114004002
Gaia: 539a25e1887b902b8b25038c547048e691bd97f6
Gecko: 42a1c35fc831
Version: 26.0
Firmware Version: v1.2-device.cfg

The audio is correctly combined into a single track.
status-b2g-v1.2: --- → unaffected
status-b2g-v1.3: --- → affected
Keywords: regression, regressionwindow-wanted

Updated

4 years ago
Blocks: 896935
blocking-b2g: --- → 1.3?
Assignee: nobody → rlin
Can't repo on 1.3 gecko on desktop build. 
Does this step 5) After three seconds, select pause on both media controls.
Application side got the onstop event?
(In reply to Randy Lin [:rlin] from comment #2)
> Can't repo on 1.3 gecko on desktop build. 
> Does this step 5) After three seconds, select pause on both media controls.
> Application side got the onstop event?

I'll investigate this on Tuesday in PST.
Keywords: regressionwindow-wanted → qawanted
QA Contact: jsmith
I can't reproduce this on a 1/19/2014 build on Buri. Works fine for me.
No longer blocks: 896935
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 4 years ago
Keywords: qawanted, regression
Resolution: --- → WORKSFORME
Component: Video/Audio → Video/Audio: Recording
You need to log in before you can comment on or make changes to this bug.