don't lto the libvpx asm_enc_offsets.S files we just assemble for offsets

RESOLVED FIXED in mozilla30

Status

RESOLVED FIXED
5 years ago
8 months ago

People

(Reporter: tbsaunde, Assigned: tbsaunde)

Tracking

unspecified
mozilla30
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

5 years ago
for one thing its pointless to lto them since they are never linked into anything, and its harmful because then the assembly file doesn't contain any useful asm.  So lets just not pass lto flags to them.
(Assignee)

Comment 1

5 years ago
Created attachment 8361986 [details] [diff] [review]
bug 961287 - don't lto files that are only compiled to assembly to get offsets

this is pretty ugh, but I'm not really sure what better option there is...  I'm also not really sure how those lines can be wrapped, but I guess they can somehow?
Attachment #8361986 - Flags: review?(mh+mozilla)
Comment on attachment 8361986 [details] [diff] [review]
bug 961287 - don't lto files that are only compiled to assembly to get offsets

Review of attachment 8361986 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/libvpx/Makefile.in
@@ +52,5 @@
>  
>  # We can extract the asm offsets directly from generated assembly using inline
>  # asm. This is the preferred method.
>  
> +vpx_scale_asm_offsets.s: CFLAGS := -DINLINE_ASM $(filter-out -f%-lto-objects -flto%,$(CFLAGS))

Just use CFLAGS := -DINLINE_ASM. We actually shouldn't need any flags here since all we care in these files are offsets in some data tables.
Attachment #8361986 - Flags: review?(mh+mozilla) → review-
(Assignee)

Comment 3

5 years ago
Created attachment 8377772 [details] [diff] [review]
bug 961287 - don't lto files that are only compiled to assembly to get offsets
Attachment #8361986 - Attachment is obsolete: true
Attachment #8377772 - Flags: review?(mh+mozilla)
Comment on attachment 8377772 [details] [diff] [review]
bug 961287 - don't lto files that are only compiled to assembly to get offsets

Review of attachment 8377772 [details] [diff] [review]:
-----------------------------------------------------------------

::: media/libvpx/Makefile.in
@@ +52,5 @@
>  
>  # We can extract the asm offsets directly from generated assembly using inline
>  # asm. This is the preferred method.
>  
> +vpx_scale_asm_offsets.s: CFLAGS := -DINLINE_ASM

Maybe add a comment to make it clear that this *is* meant to replace the entire CFLAGS, to avoid any future regression.
Attachment #8377772 - Flags: review?(mh+mozilla) → review+
https://hg.mozilla.org/mozilla-central/rev/e43584cd2994
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla30

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.