about:healthreport's totalTime is not aware of SIGTSTP

RESOLVED WONTFIX

Status

--
enhancement
RESOLVED WONTFIX
5 years ago
9 days ago

People

(Reporter: unixway.drive+moz, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20140116224729

Steps to reproduce:

* Open about:healthreport page
* p=$(pidof firefox); kill -TSTP $p; sleep 5m; kill -CONT $p
* Refresh page


Actual results:

"time open" field has it's value increased by the amount of time browser spent in a stopped state.


Expected results:

"time open" value should not include such amounts of time.
Component: Untriaged → Client: Desktop
Product: Firefox → Firefox Health Report

Comment 1

5 years ago
You are right. But I don't think this is high priority.

This likely requires support at the platform level, since we'd need to read some /proc/self data structure to get the actual process alive time as opposed to computing it from wall time. If the underlying Gecko API for process time takes SIGTSTP into consideration, FHR will get this for nearly free.

bsmedberg: Can you help me triage this to the proper Gecko component?
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(benjamin)

Updated

5 years ago
Version: 29 Branch → Trunk

Comment 2

5 years ago
Since we're measuring wall-clock time here, time when the computer is sleeping or a particular process is stopped don't figure into it.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(benjamin)
Resolution: --- → WONTFIX

Updated

9 days ago
Product: Firefox Health Report → Firefox Health Report Graveyard
You need to log in before you can comment on or make changes to this bug.