line in console does not match line shown in debugger for some large JS files

RESOLVED DUPLICATE of bug 952127

Status

DevTools
Debugger
RESOLVED DUPLICATE of bug 952127
5 years ago
5 days ago

People

(Reporter: desiradaniel2007, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Web console errors in some large JS source files do not take you to the actual source of the error.

As a test case, please run web/viewser.js in my PDF.js fork https://github.com/dannydes/seniorreader.js. The issue does not seem to occur in Chromium.

Please let me know if you need any more tests, as I have encountered the bug before but cannot remember where. Apart from that, thanks for the awesomeness Firefox devtools are becoming!
I opened the PDF.js online demo from http://mozilla.github.io/pdf.js/web/viewer.html and what I see is that there is a message in the web console from viewer.js:3109. When I click the link to the debugger I see line 3109 in the editor (though not highlighted), but it's the automatically prettified source of viewer.js, not the one with the console.log statement.

Is that what you see in your fork? Does the pretty-print icon appear depressed, and does clicking it bring you back to the original source with console.log at 3109? If so, we need to tune the heuristics of automatic pretty-printing.
Component: Developer Tools → Developer Tools: Debugger
(Reporter)

Comment 2

4 years ago
Created attachment 8374844 [details]
console.png
(Reporter)

Comment 3

4 years ago
Created attachment 8374846 [details]
debugger.png

Matching line.

Test performed on latest UX builds after enabling pretty-print.
This looks the same as bug 952127.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 952127

Updated

5 days ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.