broken link "Learn More" for Crash Reporter in options-menu Data Choices

RESOLVED FIXED

Status

www.mozilla.org
Pages & Content
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: hartnegg, Unassigned)

Tracking

Production
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1263978] )

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Go to Tools/Options/Advance/Data Choices.
Click on "Learn More" in section "Crash Reporter".


Actual results:

Goes to top of web page Privacy Policy


Expected results:

Go to section Crash Reporter of that web page, like the two other "learn more" links on the options menu do.
(Reporter)

Comment 1

4 years ago
Looks like duplicate of bug 857560, but isn't. That bug has two issues mixed into one, thus I opened a separate bug for this one.
I can reproduce this issue with latest Nightly on Win 7 64-bit.
Status: UNCONFIRMED → NEW
Component: Untriaged → Preferences
Ever confirmed: true
(Reporter)

Comment 3

4 years ago
The cause for this is in the web page, not in the browser. The html source of the web page "Privacy Policy" has no id declared for the section "crash reporter". The link on the preferences tab points to a non-existing id with name "crash-reporter".

Updated

4 years ago
Component: Preferences → Webdev
Product: Firefox → mozilla.org
Version: 26 Branch → other
The privacy policy page will be revised soon. I can work on it.
Status: NEW → ASSIGNED
Component: Webdev → Pages & Content
Depends on: 963816
OS: Windows XP → All
Product: mozilla.org → www.mozilla.org
Hardware: x86 → All
Version: other → Production
Whiteboard: [kb=1263978]
Bug 963816 is now fixed. Confirmed on the test server.
https://www.allizom.org/en-US/privacy/firefox/#crash-reporter
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

3 years ago
Depends on: 1133209
You need to log in before you can comment on or make changes to this bug.