Firefox shows status message that applies to previous page

RESOLVED WORKSFORME

Status

()

Core
Document Navigation
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: T. Bug Reporter, Unassigned)

Tracking

26 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

1.  Set your PC to use Firefox as the default "viewer" for *.ogg files.  (Not sure this is necessary, but it's how this system is configured.)

2.  For a set of test files, download <a href="http://truelinux.net/sch-i535/media.zip">this collection of cell phone ring tones</a> from <a href="http://forum.xda-developers.com/showthread.php?t=910180&page=7#post30849352">xda-developers.com</a>.  (You can probably use any collection of audio files you may have lying around, but this is how I discovered the bug.)

3.  Unzip the collection, and drag one of the larger subfolders (media\audio\ringtones is a good choice) into your Firefox window to open the folder as if it was an FTP site.

4.  Click on one of the *.ogg files, and then move the pointer up or down over the other items in the list in the second or two while Firefox is processing the click.  (You may have to try this several times to actually see the problem, as it involves timing issues that occur quickly.  You don't have to actually play the *.ogg file; if you don't see the problem immediately when the player shows up on screen, your timing was off; hit the Back button and try again.)



Actual results:

The bottom of the Firefox window shows a status message corresponding to the last file the pointer happened to be on before the *.ogg player was displayed (not the file that was actually opened).  Firefox apparently gets instructed to display this status message before the *.ogg player is displayed, and those instructions don't get canceled when or after the player actually is displayed.



Expected results:

No status message.
Hi T. Bug Reporter,

Thanks for reporting this, and sorry for the late response. Are you still having this issue?
Flags: needinfo?(thebugreporter)
Closing due to lack of response from the reporter. If you feel this is a pertinent issue, please provide the requested information and reopen. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 3

2 years ago
Sorry, I rarely sign in to Bugzilla, so I didn't notice your question about this until I came back here about another issue.  Yes, this problem still exists in Fx 45.0.2; I haven't installed 46.0 yet.  (I wasn't even aware that 46.0 was out until just now when doing testing for this.)  I'll test 46.0 tomorrow and report back - but I don't expect any change.
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
(Reporter)

Comment 4

2 years ago
Okay, I installed 46.0, and the problem doesn't seem to happen as frequently, but it is still happening.  In 45.0.2, I was able to see the misbehavior almost every time I tried to trigger it, but now it usually takes two or three tries before it happens.  (I was rather surprised to find even this much improvement in the new version, considering that no one but you has taken any interest in tracking down this bug, let alone fixing it - I thank you for that, BTW.)
Flags: needinfo?(thebugreporter)
Hi T. Bug Reporter,

I am unable to reproduce this issue on the following specs:
Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0

Can you try and reproduce the issue in the newest version of Firefox Nightly and provide a screenshot of the issue?
Flags: needinfo?(thebugreporter)
Clearing up the Untriaged list. If this is not the correct component, please re-assign to correct component as needed.
Component: Untriaged → Document Navigation
Product: Firefox → Core
(Reporter)

Comment 7

a year ago
It took me a while to figure out how to get Firefox and Nightly to stop interfering with each other, but I think I managed it.

(FYI to other readers who may be struggling with this:  you should read <http://superuser.com/questions/679797/how-to-run-firefox-nightly-alongside-firefox-at-the-same-time>, and also vote for Bug 895030 and Bug 1255740 to get this process simplified.)

After downloading firefox-50.0a1.en-US.win32.installer.exe, shutting down my normal Firefox, installing Nightly, and using it to create a new clean profile, I found that I can no longer cause the bug to occur - BUT, I also noticed that the *.ogg files start playing right after I click on them in Nightly, which doesn't happen in my regular version (now 47.0.1) with my normal profile - SO, I restarted Nightly's profile editor, created another new profile, exited, went to empty out the new profile folder but only found one file there (which I still deleted), copied everything from my regular profile folder into the new one, restarted Nightly again using that duplicate profile, and tested again.  This time, the files didn't start playing immediately when clicked, but also didn't show bogus status line text.  SO, it looks like this bug has finally been squashed.

NOW, my question is:  How long will it take before this version hits the Release channel?  (I don't intend to stick with Nightly just for this.)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years agoa year ago
Flags: needinfo?(thebugreporter)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.