Firefox 26 does not stop properly; cannot restart/startup indicates Firefox is already running

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
5 years ago
3 years ago

People

(Reporter: guy.monasterolo, Unassigned)

Tracking

26 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [support])

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8362214 [details]
maintenance-report.log

User Agent: Mozilla/5.0 (X11; Linux i686; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

I was using 25.0.1 several days ago, on Ubuntu 10.04 LTS Lucid Lynx.
Installed 26 (manually; not through Canonical): the issue described below occurs.
Fell back to 25.0.1: the issue disappears.


Actual results:

When I close firefox, whatever the page currently active, it doesn't close completely. When I restart firefox, it will display a prompt saying that firefox is still running and should be closed before restarting the session.
I doesn't depend on the time between close and restart (could be hours).
Occurs only with 26.0.0, worked perfectly until 25.0.1


Expected results:

Firefox should close and its process should stop running.
I can restart firefox by killing the running process.

Updated

5 years ago
Summary: Firefox 26 - session does not stop properly; cannot restart → Firefox 26 does not stop properly; cannot restart/startup indicates Firefox is already running
Whiteboard: [support]

Updated

5 years ago
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Comment 1

5 years ago
For these instructions to work, you need to be running a mozilla.org build of Firefox (not a canonical/ubuntu build):

When this occurs, please follow the instructions at https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox#Linux_and_Mac to abort the process which isn't quitting. This should show a crash reporter dialog. Once you have submitted the crash, paste the crash report ID in this bug so I can see what the stack trace/process state is when Firefox is hung.
Flags: needinfo?(guy.monasterolo)
(Reporter)

Comment 2

5 years ago
Thanks for the tip.
I got the following crash report, seeming to hint at a bug in the Tiddlyfox add-on module.
Will turn it off, as I don't use it any more.

Add-ons: tiddlyfox%40tiddlywiki.org:1.0alpha18,%7Bb9db16a4-6edc-47ec-a1f4-b86292ed211d%7D:4.9.21,%7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:26.0
BuildID: 20131205075310
CrashTime: 1390653502
EMCheckCompatibility: true
FramePoisonBase: 00000000f0dea000
FramePoisonSize: 4096
InstallTime: 1387968353
Notes: OpenGL: Tungsten Graphics, Inc -- Mesa DRI Intel(R) G41 GEM 20091221 2009Q4 x86/MMX/SSE2 -- 2.1 Mesa 7.7.1 -- texture_from_pixmap

ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SecondsSinceLastCrash: 1803535
StartupTime: 1390644388
Theme: classic/1.0
Throttleable: 1
URL: https://mail.google.com/mail/u/0/#inbox/143bfb7ad8468ecc
Vendor: Mozilla
Version: 26.0
useragent_locale: fr
Flags: needinfo?(guy.monasterolo)
(Reporter)

Comment 3

5 years ago
OK, removed all addons and deactivated all plugins. Still the same issue.
Couldn't find the crash report ID in the FF crash window, found one in /home/gmonaste/.mozilla/firefox/Crash\ Reports/LastCrash:
1390656317
Hope it's the right one :-)
I have tried changing page (here gmail) and use any other URL, same issue. I also truncated all addon tables from extensions.sqlite and addons.sqlite, didn't change a thing.
Good luck...

Comment 4

5 years ago
It's not the right one ;-) Did you look in about:crashes in the browser?
(Reporter)

Comment 5

5 years ago
Sorry, I hadn't :-)
Here it is then:
https://crash-stats.mozilla.com/report/index/bp-448da747-4a6d-4611-a589-58e222140125
Thanks.

Comment 6

5 years ago
It started happening to me with version 29.0 on Windows 7 pro sp1. Not always, but often. It says "firefox is already running...", and when I open the Windows Task Manager, firefox.exe *32 is there, even hours after I had closed it.

My addons are...
-------------
Extensions:
Adblock plus 2.6
BetterPrivacy 1.68
HTTPS everywhere 3.5.1
NoScript 2.6.8.20
NoSquint 2.1.9
ScrapBook 1.5.9
Self-Destructing Cookies 0.4.4
Smart Referer 0.0.11
Tree Style Tab 0.14.2014020901
-----------
Appearence:
Black (by MaDonna)
-----------
Plugins:
AdobeAAMDetect 1.0.0.0
Google Update 1.3.23.9
Shockwave Flash 13.0.0.206
-----------

But as I wrote, it didn't happen before.

Comment 7

3 years ago
Guy
Do you still see this problem when using a newer version?

https://crash-stats.mozilla.com/report/index/bp-448da747-4a6d-4611-a589-58e222140125 is ...
0	linux-gate.so	linux-gate.so@0x422	
Ø 1	libpthread-2.11.1.so	libpthread-2.11.1.so@0xa014	
2	libnspr4.so	PR_WaitCondVar	nsprpub/pr/src/pthreads/ptsynch.c
3	libnspr4.so	PR_Wait	nsprpub/pr/src/pthreads/ptsynch.c
Flags: needinfo?(guy.monasterolo)
(Reporter)

Comment 8

3 years ago
I'm not using the same Linux version, nor the same Mozilla version.

Additionally, I had set-up a "kill-switch" anyway; so the problem - if it was still present - was masked.

So, if it's only for me, I guess that you can close the ticket.

Cheers.
Flags: needinfo?(guy.monasterolo)

Comment 9

3 years ago
Thanks for the update
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.