use the mid-point as boundary for xhdpi and beyond as well

RESOLVED FIXED in mozilla29

Status

()

Core
Widget: Gonk
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: gal, Assigned: gal)

Tracking

Trunk
mozilla29
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Comment 1

4 years ago
Created attachment 8362257 [details] [diff] [review]
patch
(Assignee)

Comment 2

4 years ago
Comment on attachment 8362257 [details] [diff] [review]
patch

This makes the nexus-5 look a ton better. Please review and land if you agree.
Attachment #8362257 - Flags: review?(mwu)
(Assignee)

Comment 3

4 years ago
PS: device.mk currently selects the 1.5x assets and that should be 2.
(Assignee)

Comment 4

4 years ago
This is the 1.5 that should be set to 2:

https://github.com/mozilla-b2g/device-hammerhead/blob/b2g-4.4.2_r1/device.mk
(Assignee)

Comment 5

4 years ago
review ping
Attachment #8362257 - Flags: review?(mwu) → review+
https://hg.mozilla.org/integration/b2g-inbound/rev/11fd3aaa8320

I guess it stays the device-hammerhead part before closing this bug.
Whiteboard: [leave-open]

Comment 7

4 years ago
I've bumped the scale to 2.0. 2.5 would be ideal, but I'm not sure if the gaia asset selection code does the right thing.

I think this math is actually a bit off - doesn't this give us a 3x scale rather than 2.5x? I missed this bug, so I filed bug 963929 which uses slightly different math so we can get the scale in increments of .5 rather than 1.0. This ends up giving the nexus 5 a 2.5x scale.
Whiteboard: [leave-open]

Comment 8

4 years ago
I just tried 3.0x scale on the n5 - looks pretty good, actually.

Updated

4 years ago
Duplicate of this bug: 963929
https://hg.mozilla.org/mozilla-central/rev/11fd3aaa8320
Assignee: nobody → gal
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
You need to log in before you can comment on or make changes to this bug.