The feature "Clone This Bug" does not work for users without canconfirm rights

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Nicolas Barbulesco, Assigned: glob)

Tracking

Production

Details

(Reporter)

Description

4 years ago
At the end of the page, I have the link “Clone This Bug”. 
I click this link, to file another bug which is similar. 
The feature does not work.

It would be handy to have this feature work.

Thank you.

Nicolas Barbulesco
(Reporter)

Comment 1

4 years ago
(In reply to Nicolas Barbulesco from comment #0)

> At the end of the page, I have the link “Clone This Bug”. 

Sorry, I forgot the address of the page. Here it is : 
https://bugzilla.mozilla.org/show_bug.cgi?id=961504
What exactly do you mean by "does not work"?

When you click "Clone this bug", there should be a tiny popup asking you if you want to clone the bug to the current product or to a different product.

Both of those options appear to be working for me.
(Assignee)

Updated

4 years ago
Flags: needinfo?(nicolas.barbulesco)
(Reporter)

Comment 3

4 years ago
(In reply to Wes Kocher (:KWierso) from comment #2)

> What exactly do you mean by "does not work"?
> 
> When you click "Clone this bug", there should be a tiny popup asking you if
> you want to clone the bug to the current product or to a different product.

I have tried both of these options.

These give me the creation of a new bug file, but an empty one. Not a clone at all.
Flags: needinfo?(nicolas.barbulesco)
Yes, it opens the New Bug page, but it should have pre-filled the fields of the form with the original bug's content (except for all added comments), so the description, platform Cc list, etc are duplicated from the original bug.

Is that not happening for you?
Flags: needinfo?(nicolas.barbulesco)
One thing I could think of is that you have some extension or something that strips out the content of the request so that the Clone Bug form never gets the source bug's content?
Please verify that the &cloned_bug_id=XXX is present in the address field when you are filing the new bug. The id should be the one you are cloning from. If that is getting dropped off somehow, please give us a detailed path that you are taking (actual bug ids, etc.) and we will see where that is getting dropped. No actual data is being passed from the parent bug, the enter_bug.cgi script simply uses the cloned_bug_id to load the data directly from the DB.

dkl
(Reporter)

Comment 7

4 years ago
(In reply to Wes Kocher (:KWierso) from comment #4)

> Yes, it opens the New Bug page, but it should have pre-filled the fields of
> the form with the original bug's content (except for all added comments), so
> the description, platform Cc list, etc are duplicated from the original bug.

The fields are not pre-filled.

(In reply to David Lawrence [:dkl] from comment #6)

The address of the link "Clone This Bug" is https://bugzilla.mozilla.org/enter_bug.cgi?cloned_bug_id=961504 
I click this link. 
Bugzilla proposes me the two options. 
The option "Clone to the current product" has the address https://bugzilla.mozilla.org/enter_bug.cgi?cloned_bug_id=961504&product=Firefox&component=Session%20Restore 
I click this option. 
I land at this address : https://bugzilla.mozilla.org/enter_bug.cgi?format=guided#h=dupes|Firefox|Session Restore 
At this point, I think the cloning info is already lost.

NB
Flags: needinfo?(nicolas.barbulesco)
(Assignee)

Comment 8

4 years ago
thanks for the additional information nicolas; confirming.

the guided bug entry form doesn't support cloning; i'll update the urls to ensure the guided form isn't used in this case.
Assignee: nobody → glob
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Updated

4 years ago
Summary: The feature “Clone This Bug” does not work → The feature "Clone This Bug" does not work for users without canconfirm rights
(Assignee)

Comment 9

4 years ago
Committing to: bzr+ssh://bjones%40mozilla.com@bzr.mozilla.org/bmo/4.2/
modified extensions/BMO/web/js/edit_bug.js
modified template/en/default/bug/navigate.html.tmpl
Committed revision 9212.

this fix won't be visible on bugzilla.mozilla.org until later this week.

thanks for reporting this issue nicolas :)
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.