Ctrl+Backspace does not behave as expected when starting from a URL suggested by the awesomebar

RESOLVED DUPLICATE of bug 246237

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 246237
4 years ago
3 years ago

People

(Reporter: heycam, Assigned: Tommy Kuo (away forever...))

Tracking

Trunk
x86_64
Windows 8
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
STR:

1. Have a known URL in your history that will be suggested by the awesomebar
   -- for me it is https://svgwg.org/svg2-draft/text.html.
2. Type "text.html" then press Down until the URL is selected.
3. Press Ctrl+Backspace to delete the last word ("html"), but notice that it
   instead has highlighted the word.  (I guess it has deleted the word but
   then re-suggested it in the location bar.)
4. Press Ctrl+Backspace a second time, and notice that it has deleted the word
   prior to the "html", which is "text.".  Now the location bar contains
   "http://svgwg.org/svg2-draft/html".

I think I expect the first Ctrl+Backspace not to have reinserted and highlighted the "html".

Is there a way to have the cursor position when the "html" is reinserted and selected be set to the end of the selection?  That at least would let me hit Ctrl+Backspace a few times without the "html" remaining there.
(Assignee)

Comment 1

3 years ago
I want to try to fix it. And I found that it is also cannot delete the last word in Mac when I press Option+Delete. In Mac, Option+Delete is also a shortcut to delete one word.
Assignee: nobody → kuoe0
(Assignee)

Comment 2

3 years ago
And I also fount that when I press only Backspace (the Delete key on Mac), it will select one character. So I think the bug may be happened at the event handle for Backspace. There is the same problem on Ubuntu.
this appears fixed in Nightly...
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 4

3 years ago
Created attachment 8659419 [details]
ctrlbackspace.webm

It's not. I can still reproduce it, although the autofill only triggers for some URLs in my history, not all of them. The video I'm attaching is from the latest Nightly; I type "html", press down a few times, and then press ctrl+backspace a few times. Note that the "html" that I deleted with the first press of ctrl+backspace first gets autofilled straight back in, and then somehow ends up to the right of the cursor.

I think the fix for this would be: a) when ctrl+backspace is pressed, clear any autofilled text before processing the ctrl+backspace, and b) after ctrl+backspace is pressed, don't trigger autofill until at least one character has been typed.
yep, this is actually a duplicate. I thought it was WFM cause I couldn't reproduce on first testing, so it looks like doesn't always happen.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 246237
You need to log in before you can comment on or make changes to this bug.