Redraw problem on text zoom

RESOLVED WORKSFORME

Status

()

Core
Layout
--
trivial
RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: greg, Assigned: Marc Attinasi)

Tracking

Trunk
Future
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
A white border is drawn around the edge of the frame after
changing the text size.

Example:

Browse to a non-white-background page.
Select View->Text Size->120%

Result:
Edge of browser frame turns white.

Comment 1

16 years ago
WORKSFORME with 2001-09-08-21 on Linux. I performed the mentioned steps on
http://www.cmcwebsites.com/examples/sample20.htm and I the browser window looked
perfectly normal.

greg@wildbrain.com, what build of Mozilla are you using when you see this? Can
you give a sample URL on which you see this behaviour? Try to reproduce it with
a recent mozilla build, which you can fetch from
http://ftp.mozilla.org/pub/mozilla/nightly/latest-trunk/.

Comment 2

16 years ago
Maybe related to bug 94051. Layout.
Assignee: asa → attinasi
Component: Browser-General → Layout
QA Contact: doronr → petersen
(Reporter)

Comment 3

16 years ago
It still does it with the latest build.  Here is some html that 
clearly triggers the result:

<body text="#000000" bgcolor="#FF0000" link="#0000EE" vlink="#551A8B"
alink="#FF0000">
Hi.<br>
</body>


Load this, and then View->Text Size->120%

(Assignee)

Comment 4

16 years ago
The background is not invalidating the correct area. Cover the window and
re-expose it and it paints the background correctly.

This works fine on the 0.9.2 branch, but is broken on the trunk and the 0.9.4
branch. CC'ing some people who might know about some possible changes to the
frame invalidation or view management... Confirming and accepting as well.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 5

16 years ago
Created attachment 49108 [details]
This is the testcase.

Comment 6

16 years ago
With the testcase I can see the bug with 2001-09-11-21 on Linux.

If you change the textsize to 120% then all of the window goes white (from red)
apart from the small part that has text in it. If I hit 'reload' it is painted
correctly. Notice that going back to 100% does *not* fix it.
(Assignee)

Comment 7

16 years ago
*** Bug 94051 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Target Milestone: --- → Future

Comment 8

16 years ago
*** Bug 112855 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Summary: Redraw problem on text size change . → Redraw problem on text zoom

Comment 9

16 years ago
Bz, can you please try this testcase with your recent fix applied? Thanks.
(Reporter)

Comment 10

16 years ago
I am not seeing the problem anymore in 0.9.9 or 1.0rc1.

Greg 
This was almost certainly fixed by one of dbaron's changes to background style
stuff....
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.