APP=communications make test-integration

NEW
Unassigned

Status

Firefox OS
Gaia
4 years ago
3 years ago

People

(Reporter: yurenju, Unassigned, Mentored)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [good first bug][mentor-lang=zh])

command |APP=communications make test-integration| should run all integration tests of communications app, but it's not and only show 0 passing.

the root cause is wildcard * for rule test-integration of Makefile is incorrect.
Whiteboard: [good first bug][mentor=yurenju][mentor-lang=zh]
Brijesh, are you interested in this one?
Flags: needinfo?(brijesh.ks)
Hi, 

I am interested in working on this bug. So please can you assign this bug to me?

Thanks in advance

Regards,
A. Anup
Sure.
Assignee: nobody → allamsetty.anup
Flags: needinfo?(brijesh.ks)

Comment 4

4 years ago
I was little late to see the mail! Will anyway go through the issue and understand it. You can assign me some other issue. Thanks

Updated

4 years ago
Assignee: allamsetty.anup → nobody
(Assignee)

Updated

4 years ago
Mentor: yurenju.mozilla@gmail.com
Whiteboard: [good first bug][mentor=yurenju][mentor-lang=zh] → [good first bug][mentor-lang=zh]
Okay, I am successfully able to reproduce this bug, 0 passing is shown when the test is executed

APP=communications make test-integration

Root cause seems to be : https://github.com/mozilla-b2g/gaia/blob/977ebd0ac49dceba0a07dcb505eb324054118fc0/Makefile#L159-L164

Similar issue also exists with bluetooth. Am I heading in the right direction ?
You need to log in before you can comment on or make changes to this bug.