Intermittent TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_766001_JS_Console_in_Debugger.js | Timed out while waiting for: correct source and line test for debugger for index 2

RESOLVED FIXED in Firefox 29

Status

()

Firefox
Developer Tools: Console
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: Tomcat, Assigned: msucan)

Tracking

({intermittent-failure})

28 Branch
Firefox 29
x86
Mac OS X
intermittent-failure
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox27 unaffected, firefox28 unaffected, firefox29 fixed, firefox-esr24 unaffected)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Rev3 Fedora 12 mozilla-inbound debug test mochitest-browser-chrome on 2014-01-17 20:30:18 PST for push eb1b7ba48d22

slave: talos-r3-fed-036

https://tbpl.mozilla.org/php/getParsedLog.php?id=33215375&tree=Mozilla-Inbound



TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_bug_766001_JS_Console_in_Debugger.js | Timed out while waiting for: correct source and line test for debugger for index 2
(Assignee)

Comment 1

4 years ago
Try push for a patch I wrote: https://tbpl.mozilla.org/?tree=Try&rev=960215679a6c

I rewrote the test to be (much) simpler and easier to follow.
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
(Assignee)

Comment 2

4 years ago
Created attachment 8362912 [details] [diff] [review]
bug961621-1.diff

Try push was green. This test still used waitForSuccess() which caused problems with slow machines. Rewrote the test to make it much simpler because the webconsole and the debugger implementations have improved a lot - much easier to listen for the events that matter for the test.

r=me

Landed: https://hg.mozilla.org/integration/fx-team/rev/64e3364098fd
(Assignee)

Updated

4 years ago
Whiteboard: [fixed-in-fx-team]
(Assignee)

Updated

4 years ago
Duplicate of this bug: 961452
https://hg.mozilla.org/mozilla-central/rev/64e3364098fd
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 29
status-firefox27: --- → unaffected
status-firefox28: --- → unaffected
status-firefox29: --- → fixed
status-firefox-esr24: --- → unaffected
You need to log in before you can comment on or make changes to this bug.