bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Can't type in password after downloading Java applet, because every key I press makes two characters.

VERIFIED DUPLICATE of bug 105546

Status

Tech Evangelism Graveyard
English Other
VERIFIED DUPLICATE of bug 105546
17 years ago
3 years ago

People

(Reporter: Darren, Assigned: Margaret Chan)

Tracking

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.3+)
Gecko/20010820
BuildID:    2001082008

Internet Explorer works fine, so I know it's Mozilla. I login to hushmail with
my username and the java applet downloads. I then have to enter my password. If
I type it in normally, two stars (**) display for every character I type. If I
hold down alt or control, it's back to normal - one character per one key press
- however, my login still fails. I get a null response from the hushmail server
saying validation failed. 

Reproducible: Always
Steps to Reproduce:
1.Login to https://www.hushmail.com
2.Enter password
3.Password cannot be entered correctly; server returns null response and you
can't login

My email is dlampson555@home.com

Thanks.

Comment 1

17 years ago
I can't reproduce this with build 2001090408 on Win2k because loading
https://www.hushmail.com/ gives me a page where there's no password input box.
Only a 'Login' box @hushmail.com
Darren, I believe you have a cookie set that directly leads you to a modified
page where you only have a password to enter.
Perhaps you can give us the login only you use, then I'll be able to see the
password box.

Comment 2

17 years ago
Entering the login 'r26btc', I can skip to the next page but, then, the page
doesn't load because of Java problems.
I use build 2001090908 on Win2k with JRE 1.3.1.

java.lang.ClassFormatError: com/hush/core/security/applet/HushEncryptionEngine
(Bad magic number)
	at java.lang.ClassLoader.defineClass0(Native Method)
	at java.lang.ClassLoader.defineClass(Unknown Source)
	at java.security.SecureClassLoader.defineClass(Unknown Source)
	at sun.applet.AppletClassLoader.findClass(Unknown Source)
	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadClass(Unknown Source)
	at java.lang.ClassLoader.loadClass(Unknown Source)
	at sun.applet.AppletClassLoader.loadCode(Unknown Source)
	at sun.applet.AppletPanel.createApplet(Unknown Source)
	at sun.plugin.AppletViewer.createApplet(Unknown Source)
	at sun.applet.AppletPanel.runLoader(Unknown Source)
	at sun.applet.AppletPanel.run(Unknown Source)
	at java.lang.Thread.run(Unknown Source)

Updated

17 years ago
Status: UNCONFIRMED → NEW
Component: Browser-General → OJI
Ever confirmed: true

Comment 3

17 years ago
when moving bugs from one component to another please also check the "Reassign
bug to owner and QA contact of selected component" radio button. Thanks.
Assignee: asa → edburns
QA Contact: doronr → pmac

Comment 4

17 years ago
Reassigning to OJI's owner per Asa's comments.

Comment 5

17 years ago
Reassign to Joe as I'm leaving the role of OJI module owner.
Target Milestone: --- → mozilla0.9.5

Comment 6

17 years ago
Ressign to Joe Chou, as I am no longer working officially on OJI.
Assignee: edburns → joe.chou
Target Milestone: mozilla0.9.5 → mozilla0.9.6

Comment 7

17 years ago
*** Bug 101940 has been marked as a duplicate of this bug. ***

Comment 8

17 years ago
Should this be moved to Java to XPCOM Bridge component ?

Comment from reporter un bug 101940:

Hushmail is a popular Web-based e-mail service that offers more security
features than other choices.
They use SSL to safeguard the network connect and also a Java applet
that loads on the client and manages the e-mails.
This combination of Java + SSL seems to be too heavy for Mozilla, various versions. 
I verified that it does not work with Mozilla 0.9.4.
I am not sure if it worked with a previous version, I believe it did not work
with 0.9.x.

When you connect to your Hushmail account, you need to
1. enter an upgrade procedure for your key-pair, if you had made an account
before July 2001.
2. go directly and view your e-mails (for new accounts or those that have
carried out the transfer)

In both situations, when the password is gived, the Java applet freezes,
freezing all Mozilla instances.

To verify, try the following username/password combinations for each type:
1. When the transfer between the new type of keys is still pending
   username: auto25064
   password: bugzilla
2. For new accounts (the common case)
   username: auto2204
   bugzilla: bugzilla
Solving this problem will fix others that have to do with e-banking
where again they use big Java apps over SSL.

Such a banking WWW site that freezes when it tries to load its Java applet
is Natwest Bank (access through https://www.nwolb.co.uk). You do not need an
account to test this :), just click the "Login" link that tries to load the Java
applet. It will freeze before asking username/password.
Component: OJI → Java to XPCOM Bridge

Updated

17 years ago
Component: Java to XPCOM Bridge → OJI

Comment 9

17 years ago
The problem of the duplicate letters in the password field in Hushmail
has been solved in 0.9.4 (latest at the time JRE).

Comment 10

17 years ago
I tried the page again and the applet loads fine, I guess they've fixed
something  or my upgrading to JRE 1.4 b2 fixed the problem.

From Java Console: HushEncryptionEngine Version 2.1.0.11

Perhaps it's due to the fact I use JRE 1.4 beta2 on build 2001092703 on Win2k.

Reporter, can you try again ? If it still does not work, try with latest build
available on:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-win32-talkback.zip

Comment 11

17 years ago
(I am on Linux)

Cannot test 
  . mozilla-0.9.4 (linux) 
  . mozilla 27Sep2001 (latest nigthly build)

with JRE 1.4.0 beta2 (http://java.sun.com/j2se/1.4/jre/)
because they bring up this error:

LoadPlugin: failed to initialize shared library
/usr/lib/mozilla/plugins/libjavaplugin_oji140.so
[/usr/lib/mozilla/plugins/libjavaplugin_oji140.so: undefined symbol:
GetService__16nsServiceManagerRC4nsIDRC4nsIDPP11nsISupportsP19nsIShutdownListener]

The nightly build crashes without showing (it finds the plugin in
/usr/lib/mozilla/plugin/ without staying in its own plugin/) the above
warning first.
Tried both the oji140.so from the ns600 and ns610 directories, placing them
in the current installation's plugin directory.

I am trying right now jre-1.3.1 with latest build...

Comment 12

17 years ago
Re-assign to mtchan.
Assignee: joe.chou → mtchan
Target Milestone: mozilla0.9.6 → mozilla0.9.9

Comment 13

17 years ago
Reporter, could you try with latest build and jre 1.4?

Updated

17 years ago
Target Milestone: mozilla0.9.9 → mozilla1.0.1

Comment 14

17 years ago
Hush does not currently support Mozilla or Sun Java. See 
https://www.hushmail.com/help/v2/3.shtml

They apparently plan to add support, though.

Tech evangelism. 
Component: OJI → Europe: West
Product: Browser → Tech Evangelism
Target Milestone: mozilla1.0.1 → ---
Version: other → unspecified

Comment 15

17 years ago
Resolving as a duplicate. If this is not a duplicate, reopen.

*** This bug has been marked as a duplicate of 105546 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
New Component
Component: Europe: West → English Other
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.