"Windows 8 Touch" (switch to Metro) not appearing in Australis menu panel or customization UI on a Windows 8 tablet part 2

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: la, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0 (Beta/Release)
Build ID: 20131205075310

Steps to reproduce:

Neither the current nightly (nor any other version of Firefox) offer me a way to launch the Metro gui, there is no Button in the Australis menu, and restoring the defaults in the customization UI did not help, either.

My device is a iconia w511 tablet running win8.1,
Services.sysinfo.getProperty("hasWindowsTouchInterface") true
Services.sysinfo.getProperty('version') "6.3"
Services.sysinfo.getProperty("name") "Windows_NT"

And yes, my "default program" is Nightly.


Actual results:

No button/menu entry.


Expected results:

A shiny button that allows me to switch to metro mode.
Reporter

Updated

5 years ago
OS: Windows 7 → Windows 8.1
Hardware: x86_64 → x86

Comment 1

5 years ago
Are you in permanent private browsing? (ie, you have history disabled)
Flags: needinfo?(la)

Comment 2

5 years ago
(I'm asking because of bug 928068, which seems to indicate that because the metro version doesn't support private browsing, neither do we show UI to switch to it if you're in private browsing)
Reporter

Comment 3

5 years ago
Indeed I was, although I have no idea why, I'm pretty certain that I did not change the history settings since the only time when I've even started FF was to check whether the metro mode works...

Setting my history from "never remember history" to "remember history" and restarting nightly fixed the problem, my metro button is there, and switching to metro mode works. Yay!
Flags: needinfo?(la)

Comment 4

5 years ago
Excellent. Glad it works now!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
See also bug 961285.
Depends on: 961285
You need to log in before you can comment on or make changes to this bug.