Parameter for size of the attachment files

VERIFIED DUPLICATE of bug 91664

Status

()

--
enhancement
VERIFIED DUPLICATE of bug 91664
17 years ago
6 years ago

People

(Reporter: Leufkes, Assigned: justdave)

Tracking

Details

(Reporter)

Description

17 years ago
I have added the following statements to my createattachment.cgi to control the 
size of a single attachment file:

88    if ($ENV{"CONTENT_LENGTH"} > 524288) {
89        Punt("Attachment size greater than 512KB. Not possible.");
90    }

If you could set up a parameter for the size that can be controlled by the 
parameter-page, this could be helpful to everybody who wants to limit the size 
of a single attachment file that is stored in the DB.

For example if you take a screenshot of your workstation (like 1600x1200 with 
16mio. colors ;-)) and store this as an BMP-file (default in MSWin), the size 
limitation could force people to convert this into JPG before it is stored into 
the DB.

Without the limitation statements the size of the files is controlled by the 
max_allowed_package (=1MB) parameter of mySQL. But in my opinion even 1MB is to 
high and if you try to add a file >1MB you got an error message.

Any comments welcome.
(Reporter)

Comment 1

17 years ago
Yeah - search before edit !!

*** This bug has been marked as a duplicate of 91664 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
moving all closed Bugzilla bugs to the new Bugzilla product.
This batch is DUPLICATE/INVALID/WORKSFORME/WONTFIX
reassigning to default owner and QA in case of the bug being reopened.
Clearing milestones, since we really shouldn't have them on these types of
resolutions.  Sorry for the spam everyone...
Status: RESOLVED → NEW
Component: Bugzilla → Bugzilla-General
Product: Webtools → Bugzilla
Version: Bugzilla 2.13 → unspecified

Comment 3

17 years ago
Verified dupe
Status: RESOLVED → VERIFIED

Updated

16 years ago
Component: Bugzilla-General → attachment and request management
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.