Closed Bug 961996 Opened 6 years ago Closed 6 years ago

###!!! ASSERTION: Not in forced shutdown?: 'mGraph->mForceShutDown'

Categories

(Core :: Web Audio, defect, P1)

x86_64
Linux
defect

Tracking

()

RESOLVED FIXED
mozilla29

People

(Reporter: karlt, Assigned: karlt)

References

Details

(Keywords: regression)

Attachments

(1 file)

###!!! ASSERTION: Not in forced shutdown?: 'mGraph->mForceShutDown', file ../../../content/media/MediaStreamGraph.cpp, line 1399

Showed up in 32-bit builds at https://tbpl.mozilla.org/?tree=Try&rev=d4662ffe8dde

Those builds have patches for bug 941873 and bug 957468.
Perhaps moving the memory layout from removing mNonRealtimeIsRunning is bringing this to light.
This check was dropped in http://hg.mozilla.org/mozilla-central/rev/1ebe4da27dd5
even though MediaStreamGraphShutDownRunnable can be run when !IsEmpty() and gGraph is not cleared.
Attachment #8362866 - Flags: review?(paul)
(In reply to Karl Tomlinson (back Jan 28 :karlt) from comment #0)
> Perhaps moving the memory layout from removing mNonRealtimeIsRunning is
> bringing this to light.

https://tbpl.mozilla.org/?tree=Try&rev=6da715d1c921 does not have that patch from bug 957468, and still has these assertion failures, so perhaps bug 941873 is somehow involved.
Blocks: 941873
No longer blocks: 957468
This still asserts ?
It looks like an error in 1ebe4da27dd5 that i missed.  The code that asserts checks that it is only called in certain situations, but 1ebe4da27dd5 now calls it in other situations that don't make sense.  e.g. if gGraph is not cleared, then it is not safe to shut down the main graph thread.

https://tbpl.mozilla.org/?tree=Try&rev=ad22c80c32c5
(In reply to Karl Tomlinson (back Jan 28 :karlt) from comment #4)
> https://tbpl.mozilla.org/?tree=Try&rev=ad22c80c32c5

That was a "yes" answer to comment 3.
Priority: -- → P2
P1 because this blocks bug 941873, which is perhaps the most important web audio bug to get fixed.
Priority: P2 → P1
https://hg.mozilla.org/mozilla-central/rev/2249e151e7f0
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Depends on: 969089
You need to log in before you can comment on or make changes to this bug.