Add Bookmark causes MS Runtime Error

RESOLVED WORKSFORME

Status

P5
critical
RESOLVED WORKSFORME
18 years ago
14 years ago

People

(Reporter: joel.thibault, Assigned: bugs)

Tracking

Trunk
Future
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I went into bookmarks with Ctrl-B and opened a folder.  I chose File...New
Bookmark from the menu and got a popup error message:

   MS Visual C++ Runtime Error -- pure virtual function called

I clicked OK and then my Mozilla windows closed.  Talkback did not appear.

After reboot, I took the same steps and was able to reproduce this bug.
Doing a quick search, there are several similar bugs:
bug 73336, bug 72016, bug 86302, bug 91326, bug 70174, bug 91782

None of those looked like exactly my situation, but maybe they are related.

[Build 2001-07-28-08 on Windows NT 4]

Comment 1

18 years ago
joelt@wpi.edu, what is your build ID?  thanks.
(Reporter)

Comment 2

18 years ago
Build ID 2001072808

Comment 3

18 years ago
joelt, could you try this with a more recent build please?  This may clear up 
the problem.  Also, make sure you delete your old mozilla directory before 
reinstalling.

Thanks.
(Reporter)

Comment 4

18 years ago
Chris, I meant to try different versions today but before doing so I decided to
test a little further for repeatability.  The best I can get is what *usually*
makes it crash for me:

1. Press Ctrl+B or Click Bookmarks..Manage Bookmarks
2. Open Personal Toolbar Folder
3. Open a subfolder
4. Click once on the FIRST bookmark in that folder
5. Click File...New Bookmark
6. New Bookmark dialog appears, with this Error window on top:
------------------------------------------------------
(title: Microsoft Visual C++ Runtime Library)
(image: red circle with white X)
Runtime error!

Program C:\Program Files\mozilla.org\Mozilla\mozilla.exe

R6025
- pure virtual function call
(button: OK)
------------------------------------------------------
7. Mozilla is gone, no talkback window appears

Omitting step 4, so that a folder is highlighted, has not caused a crash for me
so far.  Also, choosing a bookmark which is not first in its folder will not
cause a crash.  

After either of these, repeating iterations of the above steps 1-7 will NOT
cause a crash either.

However, if the Manage Bookmarks window is closed and then re-opened, steps 1-7
will again be able to cause a crash. 

Hope this helps!

[again, this is build 2001072808 on Windows NT 4; I'll try other builds once I
can get the bug more repeatable] 

Comment 5

18 years ago
I believe I was seeing this problem with earlier versions a few weeks ago.  it
stopped when I grabbed a newer build,  so I never filed a bug on it.
(Reporter)

Comment 6

18 years ago
The bug still exists in 0.9.3 and Build 2001082803 (most recent nightly as of
now).  
I made sure to clean out my old mozilla directory each time before installing.
norton, which build were you using?  I'll try to reproduce it with that one.

Comment 7

17 years ago
joelt:  I didn't catch your comments until today.

No guarantees, but think I was on build 2001071604 when I was seeing this, and
think it got a lot better for me when I switched to build 2001080603.  Wish I
could  be of more help.

Comment 8

17 years ago
*** Bug 99813 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
Resolving as new, based on the duplicate. Please see comments there.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

17 years ago
*** Bug 100343 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
this bug and the dupe are reported against NT and I can't repro on Win98 - may
actually be NT only.

Comment 12

17 years ago
switching OS to ALL since this bug has been reported on Win95 as well. I still
can't reproduce however. Accepting hypotheses about why this would affect some
and not all.
OS: Windows NT → All

Comment 13

17 years ago
After your remarks I I tried to narrow it down further:
- I've never had it happen with the classic theme.
- Using the modern theme it does not happen when I have a blank page as start page.
- When I set http://www.heise.de/newsticker/ as the start page and wait until the
  page has fully loaded, it happens sometimes.
- If I move from there to a different site (i.e. slashdot) it dies consistently
  (after Ctrl+B->New Bookmark, of course) 

Comment 14

17 years ago
*** Bug 102384 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
I can confirm this bug in the 29th september trunk build in Windows 2000.

Comment 16

17 years ago
*** Bug 103735 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 17

17 years ago
FYI I just downloaded 0.9.5 and the bug is still there.
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 19

17 years ago
Mass move Ben's bugs dumped on me marked future with p5 to get off my untriaged
radar. You can filter out this email by looking for "ironstomachaussie"
Priority: -- → P5

Comment 20

17 years ago
Is anyone still seeing this in 0.9.6?
(fresh install, new profile)

Comment 21

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 22

17 years ago
joelt@wpi.edu, are you still seeing this on a recent build?
(Reporter)

Comment 23

17 years ago
I'm not seeing this bug anymore on recent builds.  (Win 98, NT 4)

Thanks all!

Ubermonkey/joelt

Comment 24

17 years ago
Good to hear!

Resolving as WFM
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.