If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

visited link does not change color

VERIFIED DUPLICATE of bug 12493

Status

SeaMonkey
UI Design
VERIFIED DUPLICATE of bug 12493
16 years ago
13 years ago

People

(Reporter: rnorberg, Assigned: Marc Attinasi)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0  Gecko/20010806
BuildID:    

A link on a webpage should change color after you have visited the page it
points to.  I have verified that the "visited links" and "unvisited linkd"
colors are different in Preferences/appearance/colors.  I have "Always use the
colors ...specified by the webpage" checked. Checking "Use my chosen colors" has
no effect. 

Reproducible: Always
Steps to Reproduce:
1.Start browser
2.Create a webpage with the following links
http://www.scienceu.com/geometry/facts/solids/handson.html
3.Click on link
4.Press Back - link to geometry figures should have changed color.

Actual Results:  Link remains same color before and after being visited

Expected Results:  link should change color after being visited.

Comment 1

16 years ago
I believe this is a dup of Bug 95687 If someone w/ power to change it agrees..
please change status/resolution.

Possibly bug 93302 is also related (There isn't much of a description on that bug)
hmmm, not sure if it'd be a dup of bug 95687... i haven't encountered this,
except while testing bug 90081 --which turned out to be my hitting up against
bug 12493...

let me grab a more recent build to test with the URL provided here...
Assignee: pchen → attinasi
tested using 2001.08.21.08-comm on linux [rh6.2]. the vlink color appears for
the "java" links i clicked, but not for the "Info Center", "Geometry Center",
etc links at the bottom. i noticed that the url's for links at the bottom are
mixed-case [http://www.ScienceU.com/] --are mixed-case url's also considered
non-canonical? if so, then this would be a dup of bug 12493.

Comment 4

16 years ago
Yes, one of the things that happens when a URL is canonicalized is that the 
hostname becomes all lower-case.  This offers some protection against spoofs 
like "paypaI.com" (where the last letter is a capital i).
dup of 12493, then.

*** This bug has been marked as a duplicate of 12493 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
mass verification of duplicate bugs: to find all bugspam pertaining to this, set
your search string to "DuplicateBugsBelongInZahadum".

if you think this particular bug is *not* a duplicate, please provide a
compelling reason, as well as check a recent *trunk* build (on the appropriate
platform[s]), before reopening.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.