Closed Bug 962393 Opened 6 years ago Closed 6 years ago

MessageManager should not use JS_InternString

Categories

(Core :: DOM: Core & HTML, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox27 --- unaffected
firefox28 --- fixed
firefox29 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: smaug, Assigned: smaug)

References

Details

(Whiteboard: [qa-])

Attachments

(2 files)

at least this compiles
Attachment #8363414 - Flags: review?(bzbarsky)
Comment on attachment 8363414 [details] [diff] [review]
JS_NewStringCopyZ

NewStringCopyN would save an strlen here.

r=me with that
Attachment #8363414 - Flags: review?(bzbarsky) → review+
N then.
Assignee: nobody → bugs
Comment on attachment 8363420 [details] [diff] [review]
JS_NewStringCopyN

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug  	916091
User impact if declined: leak
Testing completed (on m-c, etc.): landed to m-i 
Risk to taking this patch (and alternatives if risky): shouldn't be risky 
String or IDL/UUID changes made by this patch: NA
Attachment #8363420 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/7b94de064dc0
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Attachment #8363420 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Whiteboard: [qa-]
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.